Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Update travis configuration to use composer phpunit #1010

Merged
merged 1 commit into from

2 participants

@tractorcow
Owner

Since travis updated to using phpunit 4 by default our test cases (which rely on 3.7) have been breaking.
Made PHP 5.6 an allowed failure, which is due to Zend framework v1 using deprecated code.

See silverstripe-labs/silverstripe-travis-support#5

@tractorcow tractorcow added this to the 3.1.5 milestone
@hafriedlander hafriedlander merged commit 1f4d9e4 into silverstripe:3.1
@tractorcow tractorcow deleted the tractorcow:pulls/3.1-travis branch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on May 5, 2014
  1. @tractorcow

    Update travis configuration to use composer phpunit

    tractorcow authored
    Made PHP 5.6 an allowed failure
This page is out of date. Refresh to see the latest.
Showing with 4 additions and 1 deletion.
  1. +4 −1 .travis.yml
View
5 .travis.yml
@@ -26,6 +26,9 @@ matrix:
env: DB=MYSQL CORE_RELEASE=3.1
- php: 5.4
env: DB=MYSQL CORE_RELEASE=3.1 BEHAT_TEST=1
+ allow_failures:
+ - php: 5.6
+ env: DB=MYSQL CORE_RELEASE=3.1
before_script:
- composer self-update
@@ -38,7 +41,7 @@ before_script:
- php ~/travis-support/travis_setup_php54_webserver.php --if-env BEHAT_TEST
script:
- - "if [ \"$BEHAT_TEST\" = \"\" ]; then phpunit cms/tests; fi"
+ - "if [ \"$BEHAT_TEST\" = \"\" ]; then vendor/bin/phpunit cms/tests; fi"
- "if [ \"$BEHAT_TEST\" = \"1\" ]; then vendor/bin/behat @cms; fi"
after_failure:
Something went wrong with that request. Please try again.