Permalink
Browse files

API CHANGE Removed deprecated Security::encrypt_passwords() - please …

…use PasswordEncryptor_None instead.
  • Loading branch information...
1 parent 4a52e29 commit 6e58026c270c1a1c43d120acadf61e1b6e1d6ee9 @halkyon halkyon committed Mar 9, 2012
Showing with 0 additions and 23 deletions.
  1. +0 −23 security/Security.php
View
@@ -45,14 +45,6 @@ class Security extends Controller {
protected static $strictPathChecking = false;
/**
- * Should passwords be stored encrypted?
- * @deprecated 2.4 Please use 'none' as the default $encryptionAlgorithm instead
- *
- * @var bool
- */
- protected static $encryptPasswords = true;
-
- /**
* The password encryption algorithm to use by default.
* This is an arbitrary code registered through {@link PasswordEncryptor}.
*
@@ -734,21 +726,6 @@ public static function getStrictPathChecking() {
/**
- * Set if passwords should be encrypted or not
- *
- * @deprecated 2.4 Use PasswordEncryptor_None instead.
- *
- * @param bool $encrypt Set to TRUE if you want that all (new) passwords
- * will be stored encrypted, FALSE if you want to
- * store the passwords in clear text.
- */
- public static function encrypt_passwords($encrypt) {
- Deprecation::notice('2.4', 'Use PasswordEncryptor_None instead.');
- self::$encryptPasswords = (bool)$encrypt;
- }
-
-
- /**
* Get a list of all available encryption algorithms.
* Note: These are arbitrary codes, and not callable methods.
*

0 comments on commit 6e58026

Please sign in to comment.