Permalink
Browse files

BUGFIX Ensure PHPUnit 3.6 is available, show a nice message if not

  • Loading branch information...
1 parent b1e1757 commit a1d676d3532dc6eacdce73070e13cda4b6b8eb60 @halkyon halkyon committed May 9, 2012
Showing with 6 additions and 0 deletions.
  1. +6 −0 tests/bootstrap.php
View
@@ -5,6 +5,12 @@
// Make sure display_errors is on
ini_set('display_errors', 1);
+// Check we're using at least PHPUnit 3.6
+if(version_compare(PHPUnit_Runner_Version::id(), '3.6', '<')) {
+ echo 'PHPUnit 3.6 required to run tests using bootstrap.php';
+ die();
+}
+
// Fake the script name and base
global $_SERVER;
if (!$_SERVER) $_SERVER = array();

0 comments on commit a1d676d

Please sign in to comment.