Skip to content
Permalink
Browse files

;stack: use base-compat < 0.11 and latest lts for Shake/regex (#1090)

[ci skip]
  • Loading branch information
simonmichael committed Nov 29, 2019
1 parent ac5652b commit 3c226f869af1f5ad9471dafa83b4c88132fb5cfd
Showing with 12 additions and 10 deletions.
  1. +2 −1 Shake.hs
  2. +10 −9 stack.yaml
@@ -9,7 +9,8 @@
--package shake
--package time
ghc
-} -- uses the project's current stack resolver
-}
-- uses the project's default resolver & extra deps (see stack.yaml)
{-
One of two project scripts files (Makefile, Shake.hs). This one
@@ -1,7 +1,6 @@
# stack build plan using GHC 8.6.5

resolver: lts-14.4
#resolver: nightly-2019-07-26
resolver: lts-14.16

packages:
- hledger-lib
@@ -16,13 +15,15 @@ nix:
# allow-newer: true

extra-deps:
# for testing base-compat 0.11 compatibility:
- aeson-1.4.6.0
- aeson-compat-0.3.9
- attoparsec-iso8601-1.0.1.0
- base-compat-batteries-0.11.0
- base-compat-0.11.0
- http-api-data-0.4.1.1
# for Shake.hs (regex doesn't support base-compat-0.11):
- regex-1.0.2.0@rev:1
# for testing base-compat 0.11 compatibility (mutually exclusive with the above):
# - aeson-1.4.6.0
# - aeson-compat-0.3.9
# - attoparsec-iso8601-1.0.1.0
# - base-compat-batteries-0.11.0
# - base-compat-0.11.0
# - http-api-data-0.4.1.1
# for hledger-lib:
# for hledger:
# for hledger-ui:

0 comments on commit 3c226f8

Please sign in to comment.
You can’t perform that action at this time.