hledger-web needs updating for latest libs and GHC 7.8 #171

Closed
simonmichael opened this Issue Apr 7, 2014 · 5 comments

Projects

None yet

1 participant

@simonmichael
Owner
@simonmichael simonmichael reopened this Apr 16, 2014
@simonmichael simonmichael added the BUG label Apr 16, 2014
@simonmichael simonmichael changed the title from hledger-web needs updating for latest libs to hledger-web needs updating for latest libs and GHC Apr 16, 2014
@simonmichael simonmichael changed the title from hledger-web needs updating for latest libs and GHC to hledger-web needs updating for latest libs and GHC 7.8 Apr 16, 2014
@simonmichael
Owner

Installing latest alex (3.1.3) and happy (1.19.*) can help.

Still getting this:

Preprocessing library hledger-web-0.22.6...

Hledger/Web/Main.hs:18:8:
    Could not find module `Data.Conduit.Network'
    It is a member of the hidden package `conduit-extra-1.1.0.1'.
    Perhaps you need to add `conduit-extra' to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.
@simonmichael
Owner

Ah, that's what Peter's patch is for. I've released hledger-web 0.22.7 (and hledger[-lib] 0.22.2) which I hope finally fixes GHC 7.8 support for all.

@simonmichael
Owner

Assuming you've installed the latest alex and happy, I mean. Perhaps language-javascript will enforce this soon.

@simonmichael simonmichael added a commit that referenced this issue Apr 17, 2014
@simonmichael web: add Peter Simons' patch fixing Data.Conduit.Network HostIPv4 err…
…or (#171)

(cherry picked from commit 993cae3)

Conflicts:
	hledger-web/Hledger/Web/Main.hs
a9c83f0
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment