hledger 0.22.2 blocks update of hamlet packages #179

Closed
peti opened this Issue Apr 28, 2014 · 5 comments

Projects

None yet

2 participants

@peti
Collaborator
peti commented Apr 28, 2014

The current release version of hledger doesn't build with hamlet 1.2.x. It would be great if that could be remedied with a new release, because hledger is blocking a lot bunch of updates that I'd like to do in NixOS.

@simonmichael
Owner

Sorry about that. Keeping the old releases building is becoming quite a distraction from getting the new one out...

The problem is with hledger-web-0.22.7, right ? I think just need to re-release that with 499cf41.

@simonmichael
Owner

Done, let me know if that does not take care of it. Also when do you think I could safely drop support for shakespeare < 2 & hamlet < 1.2 ?

@simonmichael simonmichael added the DEPS label Apr 30, 2014
@peti
Collaborator
peti commented May 1, 2014

The problem is with hledger-web-0.22.7, right ?

Well, no, the problem is ledger: http://hydra.nixos.org/build/10696976/log/raw.

I think support for older version of shakespeare and hamlet can be dropped; we certainly don't need it in NixOS.

@simonmichael
Owner

Darn, I just saw your reply.

I don't have the brain space to figure this out right now, and would welcome a patch that keeps it installable for as many folks as possible.

@simonmichael simonmichael reopened this May 1, 2014
@simonmichael simonmichael added the hledger label May 1, 2014
@peti
Collaborator
peti commented May 3, 2014

The 0.23 release fixed all remaining issues! Thanks a lot.

@peti peti closed this May 3, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment