hledger-web dependencies could not be resolved #205

Closed
ricklupton opened this Issue Sep 10, 2014 · 3 comments

Projects

None yet

2 participants

@ricklupton
Contributor

With a fresh install of cabal:

$ cabal sandbox init
Writing a default package environment file to /home/rick/cabal.sandbox.config
Creating a new sandbox at /home/rick/.cabal-sandbox
$ cabal update
Downloading the latest package list from hackage.haskell.org
$ cabal install -j alex happy
[....]
$ cabal install -j hledger-web
Resolving dependencies...
cabal: Could not resolve dependencies:
trying: hledger-web-0.23.2 (user goal)
trying: yesod-static-1.2.4 (dependency of hledger-web-0.23.2)
trying: wai-app-static-3.0.0.1 (dependency of yesod-static-1.2.4)
next goal: warp (dependency of hledger-web-0.23.2)
rejecting: warp-3.0.1.1, 3.0.1, 3.0.0.8, 3.0.0.7, 3.0.0.6, 3.0.0.5, 3.0.0.4,
3.0.0.3, 3.0.0.2, 3.0.0.1, 3.0.0 (conflict: hledger-web => warp>=1.3 && <2.2)
rejecting: warp-2.1.5.2, 2.1.5.1, 2.1.5, 2.1.4.1, 2.1.4, 2.1.3.3, 2.1.3.2,
2.1.3.1, 2.1.3, 2.1.2.1, 2.1.2, 2.1.1.2, 2.1.1.1, 2.1.1, 2.1.0, 2.0.3.4,
2.0.3.3, 2.0.3.2, 2.0.3.1, 2.0.3, 2.0.2.1, 2.0.2, 2.0.1, 2.0.0.1, 2.0.0,
1.3.10.2, 1.3.10.1, 1.3.10, 1.3.9.2, 1.3.9.1, 1.3.9, 1.3.8.4, 1.3.8.3,
1.3.8.2, 1.3.8.1, 1.3.8, 1.3.7.5, 1.3.7.4, 1.3.7.3, 1.3.7.2, 1.3.7.1, 1.3.7,
1.3.6, 1.3.5.1, 1.3.5, 1.3.4.4, 1.3.4.3, 1.3.4.2, 1.3.4.1, 1.3.4, 1.3.3.3,
1.3.3.2, 1.3.3.1, 1.3.3, 1.3.2, 1.3.1.2, 1.3.1.1, 1.3.1, 1.3.0.1, 1.3.0
(conflict: wai-app-static => warp>=3.0 && <3.1)
rejecting: warp-1.2.2, 1.2.1.1, 1.2.1, 1.2.0.2, 1.2.0.1, 1.2.0, 1.1.0.1,
1.1.0, 1.0.0.1, 1.0.0, 0.4.6.3, 0.4.6.2, 0.4.6.1, 0.4.6, 0.4.5, 0.4.4,
0.4.3.1, 0.4.3, 0.4.2, 0.4.1.2, 0.4.1.1, 0.4.1, 0.4.0.1, 0.4.0, 0.3.3,
0.3.2.3, 0.3.2.2, 0.3.2.1, 0.3.2, 0.3.1, 0.3.0 (conflict: hledger-web =>
warp>=1.3 && <2.2)
Backjump limit reached (change with --max-backjumps).

Note: when using a sandbox, all packages are required to have consistent
dependencies. Try reinstalling/unregistering the offending packages or
recreating the sandbox.

Any suggestions?

Thanks,
Rick

@ricklupton ricklupton changed the title from hledger-web to hledger-web dependencies could not be resolved Sep 10, 2014
@simonmichael simonmichael added the DEPS label Sep 12, 2014
@simonmichael
Owner

Hi, adding --constraint 'conduit < 1.2' fixes it here - how about you ?

@simonmichael
Owner

Never mind, I think I found a better fix, now released as hledger-web-0.23.3.

@ricklupton
Contributor

Thank you for the fast response -- it installs for me now with version 0.23.3.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment