updates needed for GHC 7.10 #239

Closed
simonmichael opened this Issue Mar 27, 2015 · 1 comment

Projects

None yet

1 participant

@simonmichael
Owner
  • wizards needs bounds updates liamoc/wizards#5
  • Utils.Regex needs a type signature due to FTP
  • with time 1.5+, defaultTimeLocale is now provided by Data.Time.Format and old-locale can be dropped
  • lots of warnings need fixing
  • stringsearch needs an update https://bitbucket.org/dafis/stringsearch/issue/1 (hledger-web)
  • mwc-random can fail to build with the latest primitive bos/mwc-random#46 (hledger-web)
    (workaround: --constraint 'random < 0.6')

Here's the 7.10 migration guide

@simonmichael simonmichael changed the title from updates need for GHC 7.10 to updates needed for GHC 7.10 Mar 27, 2015
@simonmichael simonmichael added a commit that referenced this issue Mar 29, 2015
@simonmichael fix ghc 7.10 Applicative import warnings (#239)
Still needed CPP, despite using base-compat.
f75849c
@simonmichael
Owner

hledger-lib, hledger, hledger-web HEAD should now install warning-free from hackage using ghc 7.10, 7.8, and older (unless you get unlucky with mwc-random, see workaround above).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment