New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Invalid package ID: .." when trying `stack install` #513

Closed
misev opened this Issue Mar 9, 2017 · 5 comments

Comments

Projects
None yet
3 participants
@misev

misev commented Mar 9, 2017

On Ubuntu 16.04 I have this problem:

$ stack install --resolver=nightly hledger hledger-ui hledger-web
Run from outside a project, using implicit global project config
Using resolver: nightly specified on command line
Selected resolver: nightly-2017-03-08
Invalid package ID: "array-0.5.1.1 base-4.9.1.0 binary-0.8.3.0 bytestring-0.10.8.1"

Cloning the git repo and trying stack install in it gives the same result.

@simonmichael

This comment has been minimized.

Show comment
Hide comment
@simonmichael

simonmichael Mar 9, 2017

Owner

Hi there.. I searched for your error message and found this and this. What's your stack --version ?

Owner

simonmichael commented Mar 9, 2017

Hi there.. I searched for your error message and found this and this. What's your stack --version ?

@misev

This comment has been minimized.

Show comment
Hide comment
@misev

misev Mar 9, 2017

Didn't think to search the error beforehand.. :) I guess it's some issue with this stack version indeed

$ stack --version
Version 0.1.10.0 x86_64

misev commented Mar 9, 2017

Didn't think to search the error beforehand.. :) I guess it's some issue with this stack version indeed

$ stack --version
Version 0.1.10.0 x86_64
@simonmichael

This comment has been minimized.

Show comment
Hide comment
@simonmichael

simonmichael Mar 10, 2017

Owner

Assumed resolved, closing.

Owner

simonmichael commented Mar 10, 2017

Assumed resolved, closing.

@gdennie

This comment has been minimized.

Show comment
Hide comment
@gdennie

gdennie Feb 17, 2018

Isn't the purpose of Haskell's Stack suppose to prevent invalid package errors?

gdennie commented Feb 17, 2018

Isn't the purpose of Haskell's Stack suppose to prevent invalid package errors?

@simonmichael

This comment has been minimized.

Show comment
Hide comment
@simonmichael

simonmichael Feb 17, 2018

Owner

It does its best, but it's a pretty hard job. For best results you want the latest stack, and definitely not a two year old version.

Owner

simonmichael commented Feb 17, 2018

It does its best, but it's a pretty hard job. For best results you want the latest stack, and definitely not a two year old version.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment