Skip to content
Permalink
Browse files

Removed code that conditionally installs black

Since we no longer support Python 3.5 we don't need this any more.
  • Loading branch information
simonw committed Nov 12, 2019
1 parent c633c03 commit 7f89928062b1a1fdb2625a946f7cd5161e597401
Showing with 2 additions and 7 deletions.
  1. +2 −7 setup.py
@@ -22,11 +22,6 @@ def get_version():
return g["__version__"]


# Only install black on Python 3.6 or higher
maybe_black = []
if sys.version_info > (3, 6):
maybe_black = ["black~=19.10b0"]

setup(
name="datasette",
version=versioneer.get_version(),
@@ -63,8 +58,8 @@ def get_version():
"aiohttp~=3.6.2",
"beautifulsoup4~=4.8.1",
"asgiref~=3.2.3",
]
+ maybe_black,
"black~=19.10b0",
],
},
tests_require=["datasette[test]"],
classifiers=[

0 comments on commit 7f89928

Please sign in to comment.
You can’t perform that action at this time.