Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

bump uvicorn to 0.9.0 to be Python-3.8 friendly #595

Closed
wants to merge 1 commit into from

Conversation

@stonebig
Copy link

stonebig commented Oct 13, 2019

as uvicorn-0.9 is needed to get websockets-8.0.2, which is needed to have Python-3.8 compatibility

as uvicorn-0.9 is needed to get websockets-8.0.2, which is needed to have Python-3.8 compatibility
@simonw

This comment has been minimized.

Copy link
Owner

simonw commented Oct 14, 2019

Ooh this is tricky... https://travis-ci.org/simonw/datasette/jobs/597216285 failed because it looks like websockets-8.0.2 isn't compatible with Python 3.5

This is a problem. I need to keep Datasette working with 3.5 for compatibility with Glitch. But obviously I also want it to work with 3.8.

I wonder if there's a smart solution here. @tomchristie any thoughts?

@simonw simonw added the help wanted label Oct 14, 2019
@stonebig

This comment has been minimized.

Copy link
Author

stonebig commented Oct 14, 2019

Maybe make the setup rule conditional, so that below python-3.6, it looks for unicorn-0.8 ?

@tomchristie

This comment has been minimized.

Copy link

tomchristie commented Oct 14, 2019

🤷‍♂️ @stonebig's suggestion would be the best I got too, if you want to support 3.5->3.8.

It's either that, or hold off on 3.8 support until you're ready to go to 3.6->3.8.

@simonw

This comment has been minimized.

Copy link
Owner

simonw commented Oct 14, 2019

There more discussion around this on the Glitch forums here: https://support.glitch.com/t/can-you-upgrade-python-to-latest-version/7980

@simonw

This comment has been minimized.

Copy link
Owner

simonw commented Oct 14, 2019

I like the conditional dependency for the moment - maybe until 3.5 becomes officially unsupported.

@simonw

This comment has been minimized.

Copy link
Owner

simonw commented Nov 11, 2019

Glitch has been upgraded to Python 3.7. I think I'm happy to drop 3.5 support now - users who want Python 3.5 can get it by installing datasette==0.30.2

@simonw

This comment has been minimized.

Copy link
Owner

simonw commented Nov 11, 2019

@tomchristie

This comment has been minimized.

Copy link

tomchristie commented Nov 11, 2019

Glitch has been upgraded to Python 3.7.

Whoop! 🥳

@simonw

This comment has been minimized.

Copy link
Owner

simonw commented Nov 12, 2019

Closing this in favour of #627 which upgrades to uvicorn 0.10.4

@simonw simonw closed this Nov 12, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.