add warning of future removal from Perl core #3

Merged
merged 1 commit into from Jan 22, 2013

Projects

None yet

2 participants

@rjbs
Contributor
rjbs commented Jan 21, 2013

Module::Pluggable, along with a slew of other libraries added during the 5.9.x series to support CPANPLUS, is scheduled for removal for the core along with CPANPLUS itself.

This commit will add a warning when Module::Pluggable is used from its installed-with-perl location on perls 5.17.0 and greater. Once the user installs Module::Pluggable from CPAN, the warning will stop.

Once this module is released and merged into core, no further updates to Module::Pluggable in core are likely to occur. It would be great if this could be released "soon" so it can be merged back to core ASAP.

Thanks!

@simonwistow
Owner

Note to self: this forces a minimum Perl version of 5.006002 because of 'if'. I think that technically there's no reason Module::Pluggable shouldn't work on all versions of Perl5 but ... we rely on Module::Build which requires 5.006001.

@simonwistow simonwistow merged commit fd2013f into simonwistow:master Jan 22, 2013
@rjbs
Contributor
rjbs commented Jan 22, 2013

I don't think this does force 5.6.2 -- if is (believe it or not) dual-life. I made sure to put it in the Build.PL so that anyone installing on ancient perl would be afforded the chance to go get it. :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment