Permalink
Browse files

Update "ember-cli" to v2.10.0 (#1162)

* Update "ember-cli-mocha" to v0.13.1

* Update "ember-cli" to v2.8.0

* Update "ember-cli" to v2.9.1

* Update "ember-cli" to v2.10.0
  • Loading branch information...
1 parent 5f5e1c5 commit 31c002bd7dc0a037c207e8b18abf09111eb04960 @Turbo87 Turbo87 committed on GitHub Jan 4, 2017
Showing with 75 additions and 48 deletions.
  1. +2 −2 .gitignore
  2. +5 −2 .travis.yml
  3. +2 −5 bower.json
  4. +32 −6 config/ember-try.js
  5. +29 −28 package.json
  6. +4 −0 tests/dummy/config/environment.js
  7. +1 −1 tests/index.html
  8. +0 −4 tests/test-helper.js
View
@@ -1,4 +1,4 @@
-# See http://help.github.com/ignore-files/ for more about ignoring files.
+# See https://help.github.com/ignore-files/ for more about ignoring files.
.DS_Store
@@ -16,5 +16,5 @@
/connect.lock
/coverage/*
/libpeerconnection.log
-npm-debug.log
+npm-debug.log*
testem.log
View
@@ -7,11 +7,14 @@ sudo: false
cache:
directories:
- - node_modules
+ - $HOME/.npm
+ - $HOME/.cache # includes bowers cache
env:
- - EMBER_TRY_SCENARIO=default
+ # we recommend testing LTS's and latest stable release (bonus points to beta/canary)
- EMBER_TRY_SCENARIO=ember-1.12
+ - EMBER_TRY_SCENARIO=ember-lts-2.4
+ - EMBER_TRY_SCENARIO=ember-lts-2.8
- EMBER_TRY_SCENARIO=ember-release
- EMBER_TRY_SCENARIO=ember-beta
- EMBER_TRY_SCENARIO=ember-canary
View
@@ -3,11 +3,8 @@
"dependencies": {
"base64": "~1.0.0",
"bootstrap": "~3.3.7",
- "chai": "~2.3.0",
- "ember": "~2.7.0",
- "ember-cli-shims": "0.1.1",
- "ember-mocha-adapter": "~0.3.1",
- "mocha": "~2.2.4",
+ "ember": "~2.10.0",
+ "ember-cli-shims": "0.1.3",
"pretender": "~1.1.0",
"sinonjs": "~1.17.1"
}
View
@@ -2,12 +2,6 @@
module.exports = {
scenarios: [
{
- name: 'default',
- bower: {
- dependencies: {}
- }
- },
- {
name: 'ember-1.12',
bower: {
dependencies: {
@@ -23,6 +17,38 @@ module.exports = {
}
},
{
+ name: 'ember-lts-2.8',
+ bower: {
+ dependencies: {
+ 'ember': 'components/ember#lts-2-8'
+ },
+ resolutions: {
+ 'ember': 'lts-2-8'
+ }
+ },
+ npm: {
+ devDependencies: {
+ 'ember-data': '~2.8.0'
+ }
+ }
+ },
+ {
+ name: 'ember-lts-2.4',
+ bower: {
+ dependencies: {
+ 'ember': 'components/ember#lts-2-4'
+ },
+ resolutions: {
+ 'ember': 'lts-2-4'
+ }
+ },
+ npm: {
+ devDependencies: {
+ 'ember-data': '~2.4.0'
+ }
+ }
+ },
+ {
name: 'ember-release',
bower: {
dependencies: {
View
@@ -2,10 +2,16 @@
"name": "ember-simple-auth",
"version": "1.2.0-beta.1",
"description": "A lightweight library for implementing authentication/authorization with Ember.js applications.",
+ "keywords": [
+ "ember-addon"
+ ],
+ "license": "MIT",
+ "author": "simplabs GmbH",
"directories": {
"doc": "doc",
"test": "tests"
},
+ "repository": "https://github.com/simplabs/ember-simple-auth",
"scripts": {
"build": "ember build",
"fastboot": "echo \"Please also run npm start\"; ember fastboot --serve-assets",
@@ -14,40 +20,44 @@
"nodetest": "node node-tests/nodetest-runner.js",
"fastboot-nodetest": "node node-tests/fastboot-runner.js"
},
- "repository": "https://github.com/simplabs/ember-simple-auth",
- "engines": {
- "node": ">= 0.10.0"
+ "dependencies": {
+ "ember-cli-babel": "^5.1.7",
+ "ember-cli-import-polyfill": "^0.2.0",
+ "ember-cli-is-package-missing": "^1.0.0",
+ "ember-cookies": "^0.0.11",
+ "ember-getowner-polyfill": "^1.1.0",
+ "ember-network": "^0.3.0",
+ "silent-error": "^1.0.0"
},
- "author": "simplabs GmbH",
- "license": "MIT",
"devDependencies": {
"body-parser": "1.15.2",
- "broccoli-asset-rev": "^2.4.2",
+ "broccoli-asset-rev": "^2.4.5",
"broccoli-merge-trees": "^1.1.2",
"broccoli-yuidoc": "~2.1.0",
"chai": "^3.5.0",
"cors": "~2.7.1",
- "ember-ajax": "^2.0.1",
+ "ember-ajax": "^2.4.1",
"ember-browserify": "1.1.11",
- "ember-cli": "2.7.0",
+ "ember-cli": "2.10.0",
"ember-cli-addon-tests": "^0.3.0",
- "ember-cli-app-version": "^1.0.0",
+ "ember-cli-app-version": "^2.0.0",
"ember-cli-base64": "~0.0.1",
"ember-cli-blueprint-test-helpers": "~0.13.0",
+ "ember-cli-chai": "^0.3.2",
"ember-cli-content-security-policy": "~0.5.0",
- "ember-cli-dependency-checker": "^1.2.0",
+ "ember-cli-dependency-checker": "^1.3.0",
"ember-cli-fastboot": "1.0.0-beta.7",
- "ember-cli-htmlbars": "^1.0.3",
- "ember-cli-htmlbars-inline-precompile": "^0.3.1",
- "ember-cli-inject-live-reload": "^1.4.0",
- "ember-cli-jshint": "^1.0.0",
- "ember-cli-mocha": "^0.12.0",
+ "ember-cli-htmlbars": "^1.0.10",
+ "ember-cli-htmlbars-inline-precompile": "^0.3.3",
+ "ember-cli-inject-live-reload": "^1.4.1",
+ "ember-cli-jshint": "^2.0.1",
+ "ember-cli-mocha": "^0.13.1",
"ember-cli-pretender": "~0.6.0",
"ember-cli-release": "^0.2.9",
"ember-cli-sri": "^2.1.0",
"ember-cli-test-loader": "^1.1.0",
"ember-cli-uglify": "^1.2.0",
- "ember-data": "^2.7.0",
+ "ember-data": "^2.10.0",
"ember-disable-prototype-extensions": "^1.1.0",
"ember-export-application-global": "^1.0.5",
"ember-load-initializers": "^0.5.1",
@@ -58,7 +68,7 @@
"git-repo-version": "^0.3.1",
"glob": "^7.0.5",
"handlebars": "~4.0.5",
- "loader.js": "^4.0.1",
+ "loader.js": "^4.0.10",
"lodash": "^4.14.1",
"marked": "^0.3.6",
"mocha": "^3.0.0",
@@ -70,17 +80,8 @@
"sinon-chai": "~2.8.0",
"torii": "~0.8.0"
},
- "keywords": [
- "ember-addon"
- ],
- "dependencies": {
- "ember-cli-babel": "^5.1.6",
- "ember-cli-import-polyfill": "^0.2.0",
- "ember-cli-is-package-missing": "^1.0.0",
- "ember-cookies": "^0.0.11",
- "ember-getowner-polyfill": "^1.1.0",
- "ember-network": "^0.3.0",
- "silent-error": "^1.0.0"
+ "engines": {
+ "node": ">= 0.12.0"
},
"ember-addon": {
"configPath": "tests/dummy/config"
@@ -10,6 +10,10 @@ module.exports = function(environment) {
FEATURES: {
// Here you can enable experimental features on an ember canary build
// e.g. 'with-controller': true
+ },
+ EXTEND_PROTOTYPES: {
+ // Prevent Ember Data from overriding Date.parse.
+ Date: false
}
},
View
@@ -21,7 +21,7 @@
{{content-for "body"}}
{{content-for "test-body"}}
- <script src="{{rootURL}}testem.js" integrity=""></script>
+ <script src="/testem.js" integrity=""></script>
<script src="{{rootURL}}assets/vendor.js"></script>
<script src="{{rootURL}}assets/test-support.js"></script>
<script src="{{rootURL}}assets/dummy.js"></script>
@@ -1,8 +1,4 @@
-import sinonChai from 'npm:sinon-chai';
-import chai from 'chai';
import resolver from './helpers/resolver';
import { setResolver } from 'ember-mocha';
setResolver(resolver);
-
-chai.use(sinonChai);

0 comments on commit 31c002b

Please sign in to comment.