New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add .NET Standard 2.0 version #559

Closed
borrrden opened this Issue May 27, 2018 · 2 comments

Comments

2 participants
@borrrden
Contributor

borrrden commented May 27, 2018

I am filing this as a response to an issue filed on my own repo but the 1.x .NET Standard versions have a dependency on NETStandard.Library which seems to balloon the dependency list for people using packages.config (see the scary looking screenshot in the issue I linked). .NET Standard 2.0 should require only System.ComponentModel as a dependency. If you like I can try building and packaging it up and submit a PR for the nuspec.

@dotnetjunkie

This comment has been minimized.

Collaborator

dotnetjunkie commented May 28, 2018

Feel free to create a pull request for this. You can take the v4.4.x branch.

@dotnetjunkie

This comment has been minimized.

Collaborator

dotnetjunkie commented Nov 2, 2018

A new version of Simple Injector (v4.4) has been released that contains this feature/fix.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment