Skip to content
Newer
Older
100644 61 lines (52 sloc) 1.93 KB
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
1 # Why use bundler?
66a7db6 @rkh drop 1.8.6 support
rkh authored Feb 26, 2011
2 # Well, not all development dependencies install on all rubies. Moreover, `gem
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
3 # install sinatra --development` doesn't work, as it will also try to install
4 # development dependencies of our dependencies, and those are not conflict free.
5 # So, here we are, `bundle install`.
6 #
79ae9c8 @rkh typo in Gemfile comment
rkh authored Feb 21, 2011
7 # If you have issues with a gem: `bundle install --without-coffee-script`.
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
8
d269bf5 @rkh add some test guards for rbx
rkh authored Feb 21, 2011
9 RUBY_ENGINE = 'ruby' unless defined? RUBY_ENGINE
10 source :rubygems unless ENV['QUICK']
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
11
12 gem 'rake'
13 gem 'rack-test', '>= 0.5.6'
14
33cde76 @rkh allow setting tilt version via env var
rkh authored Apr 13, 2011
15 # Allows stuff like `tilt=1.2.2 bundle install` or `tilt=master ...`.
16 # Used by the CI.
01ae70e @rkh allow setting rack dependency with env var (for CI)
rkh authored May 3, 2011
17 github = "git://github.com/%s.git"
18 repos = { 'tilt' => github % "rtomayko/tilt", 'rack' => github % "rack/rack" }
19 %w[tilt rack].each do |lib|
20 dep = (ENV[lib] || 'stable').sub "#{lib}-", ''
3909b5e @rkh do not load gemspec in Gemfile
rkh authored May 3, 2011
21 dep = nil if dep == 'stable'
5a899b2 @rkh do not use git version in Gemfile if env vars for tilt or rack is not…
rkh authored May 11, 2011
22 dep = {:git => repos[lib], :branch => dep} if dep and dep !~ /(\d+\.)+\d+/
01ae70e @rkh allow setting rack dependency with env var (for CI)
rkh authored May 3, 2011
23 gem lib, dep
33cde76 @rkh allow setting tilt version via env var
rkh authored Apr 13, 2011
24 end
25
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
26 gem 'haml', '>= 3.0', :group => 'haml'
a7bf182 @rkh sass 3.1 has been released
rkh authored Apr 26, 2011
27 gem 'sass', :group => 'sass'
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
28 gem 'builder', :group => 'builder'
29 gem 'erubis', :group => 'erubis'
30 gem 'less', :group => 'less'
31 gem 'liquid', :group => 'liquid'
32 gem 'nokogiri', :group => 'nokogiri'
33 gem 'slim', :group => 'slim'
27b1008 @rkh make the bundle install on macruby
rkh authored May 10, 2011
34 gem 'RedCloth', :group => 'redcloth' if RUBY_VERSION < "1.9.3" and RUBY_ENGINE != 'macruby'
66a7db6 @rkh drop 1.8.6 support
rkh authored Feb 26, 2011
35 gem 'coffee-script', '>= 2.0', :group => 'coffee-script'
36 gem 'rdoc', :group => 'rdoc'
4b8aaef @rkh test all mardown engines if available
rkh authored Apr 15, 2011
37 gem 'kramdown', :group => 'kramdown'
38 gem 'maruku', :group => 'maruku'
9ce9e54 @rkh add support for creole templates
rkh authored Apr 15, 2011
39 gem 'creole', :group => 'creole'
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
40
8dc9e35 @rkh jruby 1.6.1 now is able to gem install cexts out of the box
rkh authored May 17, 2011
41 unless RUBY_ENGINE == 'jruby' && JRUBY_VERSION < "1.6.1"
42 # C extensions
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
43 gem 'rdiscount', :group => 'rdiscount'
6fbee52 @rkh add redcarpet to gemfile and requirements docs
rkh authored May 17, 2011
44 gem 'redcarpet', :group => 'redcarpet'
8dc9e35 @rkh jruby 1.6.1 now is able to gem install cexts out of the box
rkh authored May 17, 2011
45
103bfa8 @rkh remove bluecloth from bundle for now (broken)
rkh authored Apr 27, 2011
46 ## bluecloth is broken
47 #gem 'bluecloth', :group => 'bluecloth'
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
48 end
49
50 platforms :ruby_18, :jruby do
51 gem 'json', :group => 'coffee-script'
52 gem 'markaby', :group => 'markaby'
53 gem 'radius', :group => 'radius'
64f6052 @rkh Use platforms properly in Gemfile, even though bundler is broken.
rkh authored Feb 26, 2011
54 end
55
56 platforms :mri_18 do
57 # bundler platforms are broken
ee2e348 @rkh Merge branch 'drop-1.8.6'
rkh authored Mar 19, 2011
58 next if RUBY_ENGINE != 'ruby' or RUBY_VERSION > "1.8"
64f6052 @rkh Use platforms properly in Gemfile, even though bundler is broken.
rkh authored Feb 26, 2011
59 gem 'rcov', :group => 'rcov'
60 end
Something went wrong with that request. Please try again.