Skip to content
This repository
Newer
Older
100644 57 lines (48 sloc) 1.804 kb
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
1 # Why use bundler?
2 # Well, not all development dependencies install on all rubies. Moreover, `gem
3 # install sinatra --development` doesn't work, as it will also try to install
4 # development dependencies of our dependencies, and those are not conflict free.
5 # So, here we are, `bundle install`.
6 #
79ae9c8a »
2011-02-21 typo in Gemfile comment
7 # If you have issues with a gem: `bundle install --without-coffee-script`.
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
8
d269bf5a »
2011-02-21 add some test guards for rbx
9 RUBY_ENGINE = 'ruby' unless defined? RUBY_ENGINE
10 source :rubygems unless ENV['QUICK']
76ac145c »
2012-03-13 add backports as a dependency
11 gemspec
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
12
dd21d967 »
2011-06-01 depend on rake 0.8
13 gem 'rake', '~> 0.8.7'
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
14 gem 'rack-test', '>= 0.5.6'
b7278700 »
2011-06-09 Make CI Reporter optional
15 gem 'ci_reporter', :group => :ci
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
16
1c1fa17b »
2011-04-13 allow setting tilt version via env var
17 # Allows stuff like `tilt=1.2.2 bundle install` or `tilt=master ...`.
18 # Used by the CI.
9ca16a87 »
2011-05-03 allow setting rack dependency with env var (for CI)
19 github = "git://github.com/%s.git"
20 repos = { 'tilt' => github % "rtomayko/tilt", 'rack' => github % "rack/rack" }
21 %w[tilt rack].each do |lib|
22 dep = (ENV[lib] || 'stable').sub "#{lib}-", ''
649b6fb7 »
2011-05-03 do not load gemspec in Gemfile
23 dep = nil if dep == 'stable'
15dca9ca »
2011-05-11 do not use git version in Gemfile if env vars for tilt or rack is not…
24 dep = {:git => repos[lib], :branch => dep} if dep and dep !~ /(\d+\.)+\d+/
8fb2d96a »
2011-05-03 adjust gemfile for 1.8.6
25 dep ||= '~> 1.1.0' if lib == 'rack' and RUBY_VERSION == '1.8.6'
9ca16a87 »
2011-05-03 allow setting rack dependency with env var (for CI)
26 gem lib, dep
1c1fa17b »
2011-04-13 allow setting tilt version via env var
27 end
28
8fb2d96a »
2011-05-03 adjust gemfile for 1.8.6
29 gem 'haml', '~> 3.0.0', :group => 'haml'
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
30 gem 'builder', :group => 'builder'
31 gem 'erubis', :group => 'erubis'
32 gem 'liquid', :group => 'liquid'
33
4ede00c9 »
2011-02-21 fix Gemfile for 1.8.6
34 if RUBY_VERSION > '1.8.6'
7a15be53 »
2012-03-13 adjust Gemfile to install on 1.8.6 (but skip most dependencies)
35 gem 'less', '~> 1.0', :group => 'less'
36 gem 'slim', :group => 'slim'
37 gem 'RedCloth', :group => 'redcloth' if RUBY_VERSION < "1.9.3" and RUBY_ENGINE != 'macruby'
38
5dafb15e »
2011-07-21 dont run against nokogiri 1.5.0 on jruby
39 if RUBY_ENGINE == 'jruby'
40 gem 'nokogiri', '!= 1.5.0'
41 elsif RUBY_ENGINE != 'maglev'
42 gem 'nokogiri'
43 end
4ede00c9 »
2011-02-21 fix Gemfile for 1.8.6
44 gem 'coffee-script', '>= 2.0', :group => 'coffee-script'
1b72c7c7 »
2011-10-10 stick to RDoc < 3.10
45 gem 'rdoc', '< 3.10', :group => 'rdoc'
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
46
7a15be53 »
2012-03-13 adjust Gemfile to install on 1.8.6 (but skip most dependencies)
47 platforms :ruby do
48 gem 'rdiscount', :group => 'rdiscount'
49 end
64f60526 »
2011-02-26 Use platforms properly in Gemfile, even though bundler is broken.
50
7a15be53 »
2012-03-13 adjust Gemfile to install on 1.8.6 (but skip most dependencies)
51 if RUBY_VERSION < '1.9'
52 gem 'json', :group => 'coffee-script'
53 gem 'markaby', :group => 'markaby'
54 gem 'radius', :group => 'radius'
55 end
64f60526 »
2011-02-26 Use platforms properly in Gemfile, even though bundler is broken.
56 end
Something went wrong with that request. Please try again.