Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 56 lines (47 sloc) 1.728 kb
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored
1 # Why use bundler?
2 # Well, not all development dependencies install on all rubies. Moreover, `gem
3 # install sinatra --development` doesn't work, as it will also try to install
4 # development dependencies of our dependencies, and those are not conflict free.
5 # So, here we are, `bundle install`.
6 #
79ae9c8 @rkh typo in Gemfile comment
rkh authored
7 # If you have issues with a gem: `bundle install --without-coffee-script`.
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored
8
d269bf5 @rkh add some test guards for rbx
rkh authored
9 RUBY_ENGINE = 'ruby' unless defined? RUBY_ENGINE
10 source :rubygems unless ENV['QUICK']
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored
11
12 gem 'rake'
13 gem 'rack-test', '>= 0.5.6'
14
1c1fa17 @rkh allow setting tilt version via env var
rkh authored
15 # Allows stuff like `tilt=1.2.2 bundle install` or `tilt=master ...`.
16 # Used by the CI.
9ca16a8 @rkh allow setting rack dependency with env var (for CI)
rkh authored
17 github = "git://github.com/%s.git"
18 repos = { 'tilt' => github % "rtomayko/tilt", 'rack' => github % "rack/rack" }
19 %w[tilt rack].each do |lib|
20 dep = (ENV[lib] || 'stable').sub "#{lib}-", ''
649b6fb @rkh do not load gemspec in Gemfile
rkh authored
21 dep = nil if dep == 'stable'
9ca16a8 @rkh allow setting rack dependency with env var (for CI)
rkh authored
22 dep = {:git => repos[lib], :branch => dep} unless dep =~ /(\d+\.)+\d+/
8fb2d96 @rkh adjust gemfile for 1.8.6
rkh authored
23 dep ||= '~> 1.1.0' if lib == 'rack' and RUBY_VERSION == '1.8.6'
9ca16a8 @rkh allow setting rack dependency with env var (for CI)
rkh authored
24 gem lib, dep
1c1fa17 @rkh allow setting tilt version via env var
rkh authored
25 end
26
8fb2d96 @rkh adjust gemfile for 1.8.6
rkh authored
27 gem 'haml', '~> 3.0.0', :group => 'haml'
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored
28 gem 'builder', :group => 'builder'
29 gem 'erubis', :group => 'erubis'
30 gem 'less', :group => 'less'
31 gem 'liquid', :group => 'liquid'
32 gem 'nokogiri', :group => 'nokogiri'
33 gem 'slim', :group => 'slim'
ff43387 @rkh RedCloth has issues on 1.9.3
rkh authored
34 gem 'RedCloth', :group => 'redcloth' if RUBY_VERSION < "1.9.3"
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored
35
4ede00c @rkh fix Gemfile for 1.8.6
rkh authored
36 if RUBY_VERSION > '1.8.6'
37 gem 'coffee-script', '>= 2.0', :group => 'coffee-script'
38 gem 'rdoc', :group => 'rdoc'
39 end
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored
40
41 platforms :ruby do
42 gem 'rdiscount', :group => 'rdiscount'
43 end
44
45 platforms :ruby_18, :jruby do
46 gem 'json', :group => 'coffee-script'
47 gem 'markaby', :group => 'markaby'
48 gem 'radius', :group => 'radius'
64f6052 @rkh Use platforms properly in Gemfile, even though bundler is broken.
rkh authored
49 end
50
51 platforms :mri_18 do
52 # bundler platforms are broken
53 next unless RUBY_ENGINE == 'ruby'
54 gem 'rcov', :group => 'rcov'
55 end
Something went wrong with that request. Please try again.