Skip to content
This repository
Newer
Older
100644 82 lines (70 sloc) 1.982 kb
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
1 # Why use bundler?
66a7db6c »
2011-02-26 drop 1.8.6 support
2 # Well, not all development dependencies install on all rubies. Moreover, `gem
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
3 # install sinatra --development` doesn't work, as it will also try to install
4 # development dependencies of our dependencies, and those are not conflict free.
5 # So, here we are, `bundle install`.
6 #
79ae9c8a »
2011-02-21 typo in Gemfile comment
7 # If you have issues with a gem: `bundle install --without-coffee-script`.
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
8
d269bf5a »
2011-02-21 add some test guards for rbx
9 RUBY_ENGINE = 'ruby' unless defined? RUBY_ENGINE
10 source :rubygems unless ENV['QUICK']
1f1e58e2 »
2011-09-02 add rack-protection, fixes #310
11 gemspec
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
12
13 gem 'rake'
14 gem 'rack-test', '>= 0.5.6'
e187ec85 »
2011-06-09 Make CI Reporter optional
15 gem 'ci_reporter', :group => :ci
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
16
33cde76d »
2011-04-13 allow setting tilt version via env var
17 # Allows stuff like `tilt=1.2.2 bundle install` or `tilt=master ...`.
18 # Used by the CI.
01ae70e2 »
2011-05-03 allow setting rack dependency with env var (for CI)
19 github = "git://github.com/%s.git"
20 repos = { 'tilt' => github % "rtomayko/tilt", 'rack' => github % "rack/rack" }
21 %w[tilt rack].each do |lib|
22 dep = (ENV[lib] || 'stable').sub "#{lib}-", ''
3909b5e5 »
2011-05-03 do not load gemspec in Gemfile
23 dep = nil if dep == 'stable'
5a899b2d »
2011-05-11 do not use git version in Gemfile if env vars for tilt or rack is not…
24 dep = {:git => repos[lib], :branch => dep} if dep and dep !~ /(\d+\.)+\d+/
01ae70e2 »
2011-05-03 allow setting rack dependency with env var (for CI)
25 gem lib, dep
33cde76d »
2011-04-13 allow setting tilt version via env var
26 end
27
1f6d9d52 »
2011-06-16 clean up gemfile a little
28 gem 'haml', '>= 3.0'
29 gem 'sass'
30 gem 'builder'
31 gem 'erubis'
32 gem 'less', '~> 1.0'
811cbb3c »
2011-09-01 make sure we are running slim 1.0
33
8cc5f016 »
2011-08-11 Updating Gemfile to include gems that now also work on MagLev.
34 if RUBY_ENGINE == "maglev"
35 gem 'liquid', :git => "https://github.com/Shopify/liquid.git"
36 else
37 gem 'liquid'
38 end
811cbb3c »
2011-09-01 make sure we are running slim 1.0
39
40 gem 'slim', '~> 1.0'
f40e43d2 »
2011-09-02 skip temple 0.3.3
41 gem 'temple', '!= 0.3.3'
1f6d9d52 »
2011-06-16 clean up gemfile a little
42 gem 'RedCloth' if RUBY_VERSION < "1.9.3" and not RUBY_ENGINE.start_with? 'ma'
8cc5f016 »
2011-08-11 Updating Gemfile to include gems that now also work on MagLev.
43 gem 'coffee-script', '>= 2.0'
1f6d9d52 »
2011-06-16 clean up gemfile a little
44 gem 'rdoc'
45 gem 'kramdown'
46 gem 'maruku'
47 gem 'creole'
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
48
dfbe9f40 »
2011-07-21 dont run against nokogiri 1.5.0 on jruby
49 if RUBY_ENGINE == 'jruby'
50 gem 'nokogiri', '!= 1.5.0'
f1b35074 »
2011-08-18 load jruby-openssl when testing on jruby
51 gem 'jruby-openssl'
dfbe9f40 »
2011-07-21 dont run against nokogiri 1.5.0 on jruby
52 elsif RUBY_ENGINE != 'maglev'
53 gem 'nokogiri'
54 end
f3f34f8d »
2011-05-20 adjust gemfile to install on maglev
55
43c06252 »
2011-08-01 Revert "dont run c exts on jruby on travis"
56 unless RUBY_ENGINE == 'jruby' && JRUBY_VERSION < "1.6.1"
8dc9e35f »
2011-05-17 jruby 1.6.1 now is able to gem install cexts out of the box
57 # C extensions
1f6d9d52 »
2011-06-16 clean up gemfile a little
58 gem 'rdiscount'
59 gem 'redcarpet'
89c6a38a »
2011-06-05 Revert "enable bluecloth"
60
61 ## bluecloth is broken
1f6d9d52 »
2011-06-16 clean up gemfile a little
62 #gem 'bluecloth'
5a3f133d »
2011-02-18 Add Gemfile, fixes #152.
63 end
64
c594558c »
2011-06-16 adjust gemfile for maglev. coffee-script broken b/c json gem doesn't …
65 if RUBY_ENGINE == 'maglev'
8cc5f016 »
2011-08-11 Updating Gemfile to include gems that now also work on MagLev.
66 gem 'json', :git => "https://github.com/MagLev/json.git"
1f6d9d52 »
2011-06-16 clean up gemfile a little
67 gem 'markaby'
68 gem 'radius'
8cc5f016 »
2011-08-11 Updating Gemfile to include gems that now also work on MagLev.
69 else
70 platforms :ruby_18, :jruby do
71 gem 'json'
72 gem 'markaby'
73 gem 'radius'
74 end
64f60526 »
2011-02-26 Use platforms properly in Gemfile, even though bundler is broken.
75 end
76
77 platforms :mri_18 do
78 # bundler platforms are broken
ee2e348f »
2011-03-19 Merge branch 'drop-1.8.6'
79 next if RUBY_ENGINE != 'ruby' or RUBY_VERSION > "1.8"
1f6d9d52 »
2011-06-16 clean up gemfile a little
80 gem 'rcov'
64f60526 »
2011-02-26 Use platforms properly in Gemfile, even though bundler is broken.
81 end
Something went wrong with that request. Please try again.