Skip to content
Newer
Older
100644 68 lines (61 sloc) 1.44 KB
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
1 # Why use bundler?
66a7db6 @rkh drop 1.8.6 support
rkh authored Feb 26, 2011
2 # Well, not all development dependencies install on all rubies. Moreover, `gem
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
3 # install sinatra --development` doesn't work, as it will also try to install
4 # development dependencies of our dependencies, and those are not conflict free.
5 # So, here we are, `bundle install`.
6 #
79ae9c8 @rkh typo in Gemfile comment
rkh authored Feb 21, 2011
7 # If you have issues with a gem: `bundle install --without-coffee-script`.
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
8
d269bf5 @rkh add some test guards for rbx
rkh authored Feb 21, 2011
9 RUBY_ENGINE = 'ruby' unless defined? RUBY_ENGINE
8f19104 @patriciomacadden fix gemfile source.
patriciomacadden authored Mar 7, 2013
10 source 'https://rubygems.org' unless ENV['QUICK']
1f1e58e @rkh add rack-protection, fixes #310
rkh authored Sep 2, 2011
11 gemspec
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
12
13 gem 'rake'
6aea9f8 @TrevorBramble Raise Rack version requirement to 2.x
TrevorBramble authored Sep 12, 2015
14 gem 'rack', github: 'rack/rack'
74a79fe @DamirSvrtan Update rack-test dependency to use a newer version.
DamirSvrtan authored Jun 21, 2014
15 gem 'rack-test', '>= 0.6.2'
9cd17b5 @vipulnsward - Add minitest dependencies for all rubies
vipulnsward authored Jan 11, 2015
16 gem "minitest", "~> 5.0"
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
17
dfbe9f4 @rkh dont run against nokogiri 1.5.0 on jruby
rkh authored Jul 21, 2011
18 if RUBY_ENGINE == 'jruby'
19 gem 'nokogiri', '!= 1.5.0'
700d5b2 @rkh add mizuno
rkh authored May 13, 2012
20 gem 'trinidad'
dfbe9f4 @rkh dont run against nokogiri 1.5.0 on jruby
rkh authored Jul 21, 2011
21 end
f3f34f8 @rkh adjust gemfile to install on maglev
rkh authored May 20, 2011
22
af18cf5 @TrevorBramble Raise supported/expected dependency versions
TrevorBramble authored Jul 26, 2015
23 if RUBY_ENGINE == "ruby"
5fdfa0d @timfel therubyracer is very unstable/crashes often on rbx,jruby and maglev -…
timfel authored Oct 6, 2011
24 gem 'less', '~> 2.0'
a570335 @rkh reduce number of template languages tested on 1.8, most of them do no…
rkh authored Dec 27, 2013
25 gem 'therubyracer'
26 gem 'redcarpet'
27 gem 'wlang', '>= 2.0.1'
28 gem 'bluecloth'
29 gem 'rdiscount'
30 gem 'RedCloth'
b5bbb27 @rkh add puma to Gemfile
rkh authored Mar 18, 2012
31 gem 'puma'
6aea9f8 @TrevorBramble Raise Rack version requirement to 2.x
TrevorBramble authored Sep 13, 2015
32 #TODO: remove explicit require once net-http-server does it
33 #(apparently it was shipped w/ stdlib in Rubies < 2.2.2)
34 gem 'gserver'
a570335 @rkh reduce number of template languages tested on 1.8, most of them do no…
rkh authored Dec 27, 2013
35 gem 'net-http-server'
36 gem 'yajl-ruby'
37 gem 'nokogiri'
38 gem 'thin'
2697ced @DamirSvrtan Update slim dependency to use a newer version.
DamirSvrtan authored Jun 21, 2014
39 gem 'slim', '~> 2.0'
a570335 @rkh reduce number of template languages tested on 1.8, most of them do no…
rkh authored Dec 27, 2013
40 gem 'coffee-script', '>= 2.0'
41 gem 'rdoc'
42 gem 'kramdown'
43 gem 'maruku'
44 gem 'creole'
baae681 @rkh Merge branch 'mediawiki-support' of https://github.com/somu/sinatra
rkh authored Feb 21, 2014
45 gem 'wikicloth'
a570335 @rkh reduce number of template languages tested on 1.8, most of them do no…
rkh authored Dec 27, 2013
46 gem 'markaby'
47 gem 'radius'
0cb6679 @rkh Merge branch 'asciidoctor-support' of https://github.com/somu/sinatra
rkh authored Feb 21, 2014
48 gem 'asciidoctor'
a570335 @rkh reduce number of template languages tested on 1.8, most of them do no…
rkh authored Dec 27, 2013
49 gem 'liquid'
50 gem 'stylus'
51 gem 'rabl'
52 gem 'builder'
53 gem 'erubis'
54 gem 'haml', '>= 3.0'
46743ff @vipulnsward Sass works on ruby 2.1. Enable back tests against it.
vipulnsward authored Feb 17, 2014
55 gem 'sass'
e61370a @zzak Add Reel support.
zzak authored Jan 31, 2016
56 gem 'reel-rack'
5a3f133 @rkh Add Gemfile, fixes #152.
rkh authored Feb 18, 2011
57 end
58
a570335 @rkh reduce number of template languages tested on 1.8, most of them do no…
rkh authored Dec 27, 2013
59 if RUBY_ENGINE == "rbx"
60 gem 'json'
61 gem 'rubysl'
62 gem 'rubysl-test-unit'
63 end
6ec5234 @rkh be smarter about servers
rkh authored May 13, 2012
64
af18cf5 @TrevorBramble Raise supported/expected dependency versions
TrevorBramble authored Jul 27, 2015
65 platforms :jruby do
66 gem 'json'
64f6052 @rkh Use platforms properly in Gemfile, even though bundler is broken.
rkh authored Feb 26, 2011
67 end
Something went wrong with that request. Please try again.