Permalink
Browse files

clean up gemfile a little

  • Loading branch information...
1 parent 304e050 commit 1f6d9d52a76328ec58cdc00c3ce72c1607d118c9 @rkh rkh committed Jun 16, 2011
Showing with 24 additions and 27 deletions.
  1. +24 −27 Gemfile
View
51 Gemfile
@@ -24,48 +24,45 @@ repos = { 'tilt' => github % "rtomayko/tilt", 'rack' => github % "rack/rack" }
gem lib, dep
end
-gem 'haml', '>= 3.0', :group => 'haml'
-gem 'sass', :group => 'sass'
-gem 'builder', :group => 'builder'
-gem 'erubis', :group => 'erubis'
-gem 'less', '~> 1.0', :group => 'less'
-gem 'liquid', :group => 'liquid' unless RUBY_ENGINE == 'maglev'
-gem 'slim', :group => 'slim'
-gem 'RedCloth', :group => 'redcloth' if RUBY_VERSION < "1.9.3" and not RUBY_ENGINE.start_with? 'ma'
-gem 'coffee-script', '>= 2.0', :group => 'coffee-script' unless RUBY_ENGINE == 'maglev'
-gem 'rdoc', :group => 'rdoc'
-gem 'kramdown', :group => 'kramdown'
-gem 'maruku', :group => 'maruku'
-gem 'creole', :group => 'creole'
+gem 'haml', '>= 3.0'
+gem 'sass'
+gem 'builder'
+gem 'erubis'
+gem 'less', '~> 1.0'
+gem 'liquid' unless RUBY_ENGINE == 'maglev'
+gem 'slim'
+gem 'RedCloth' if RUBY_VERSION < "1.9.3" and not RUBY_ENGINE.start_with? 'ma'
+gem 'coffee-script', '>= 2.0' unless RUBY_ENGINE == 'maglev'
+gem 'rdoc'
+gem 'kramdown'
+gem 'maruku'
+gem 'creole'
-gem 'nokogiri', :group => 'nokogiri' if RUBY_ENGINE != 'maglev'
-#nokogiri_options = {:group => 'nokogiri'}
-#nokogiri_options[:git] = "https://github.com/MagLev/nokogiri.git" if RUBY_ENGINE == 'maglev'
-#gem 'nokogiri', nokogiri_options if RUBY_ENGINE != 'maglev'
+gem 'nokogiri' if RUBY_ENGINE != 'maglev'
unless RUBY_ENGINE == 'jruby' && JRUBY_VERSION < "1.6.1"
# C extensions
- gem 'rdiscount', :group => 'rdiscount'
- gem 'redcarpet', :group => 'redcarpet'
+ gem 'rdiscount'
+ gem 'redcarpet'
## bluecloth is broken
- #gem 'bluecloth', :group => 'bluecloth'
+ #gem 'bluecloth'
end
if RUBY_ENGINE == 'maglev'
- gem 'json', :group => 'coffee-script'
- gem 'markaby', :group => 'markaby'
- gem 'radius', :group => 'radius'
+ gem 'json'
+ gem 'markaby'
+ gem 'radius'
end
platforms :ruby_18, :jruby do
- gem 'json', :group => 'coffee-script'
- gem 'markaby', :group => 'markaby'
- gem 'radius', :group => 'radius'
+ gem 'json'
+ gem 'markaby'
+ gem 'radius'
end
platforms :mri_18 do
# bundler platforms are broken
next if RUBY_ENGINE != 'ruby' or RUBY_VERSION > "1.8"
- gem 'rcov', :group => 'rcov'
+ gem 'rcov'
end

0 comments on commit 1f6d9d5

Please sign in to comment.