Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

reduce build matrix, depend on newer rack

  • Loading branch information...
commit abf87d742622a5517a06aa1b5c466c51ef7cb7e9 1 parent cdd4618
@rkh rkh authored
Showing with 7 additions and 17 deletions.
  1. +5 −15 .travis.yml
  2. +2 −2 sinatra.gemspec
View
20 .travis.yml
@@ -1,3 +1,4 @@
+---
rvm:
- 1.8.7
- 1.9.2
@@ -8,19 +9,8 @@ rvm:
- jruby-19mode
- jruby-head
- ruby-head
-env:
- - "rack=1.3.6"
- - "rack=1.4.1"
- - "rack=master"
- - "tilt=1.3.3"
- - "tilt=master"
-# using env: would cause many permutations to exclude, so...
-before_install:
- - export JRUBY_OPTS="--server -Xcext.enabled=false -Xcompile.invokedynamic=false"
matrix:
- allow_failures:
- - rvm: ruby-head
- - rvm: jruby-head
-notifications:
- recipients:
- - k.haase@finn.de
+ include:
+ - { rvm: 1.8.7, env: tilt=master }
+ - { rvm: 1.9.3, env: rack=master }
+ - { rvm: 1.9.3, env: tilt=master }
View
4 sinatra.gemspec
@@ -12,7 +12,7 @@ Gem::Specification.new 'sinatra', Sinatra::VERSION do |s|
s.extra_rdoc_files = s.files.select { |p| p =~ /^README/ } << 'LICENSE'
s.rdoc_options = %w[--line-numbers --inline-source --title Sinatra --main README.rdoc --encoding=UTF-8]
- s.add_dependency 'rack', '~> 1.3', '>= 1.3.6'
- s.add_dependency 'rack-protection', '~> 1.2'
+ s.add_dependency 'rack', '~> 1.4'
+ s.add_dependency 'rack-protection', '~> 1.3'
s.add_dependency 'tilt', '~> 1.3', '>= 1.3.3'
end
Please sign in to comment.
Something went wrong with that request. Please try again.