Permalink
Browse files

update supported versions in spanish readme

Signed-off-by: Konstantin Haase <konstantin.mailinglists@googlemail.com>
  • Loading branch information...
1 parent 7949da7 commit e68e2191f90697313006b06ef7c7b6a2b301e364 @gnandretta gnandretta committed with rkh Mar 18, 2011
Showing with 14 additions and 9 deletions.
  1. +14 −9 README.es.rdoc
View
@@ -1756,30 +1756,35 @@ Las siguientes versiones de Ruby son soportadas oficialmente:
fallos de segmentación cuando se utiliza Sinatra.
[ Rubinius ]
- Rubinius es soportado oficialmente (Rubinius >= 1.2.2), con la excepción de
- las plantillas Textile.
+ Rubinius es soportado oficialmente (Rubinius >= 1.2.3). Todo
+ funciona correctamente, incluyendo los lenguajes de plantillas.
[ JRuby ]
- JRuby es soportado oficialmente (JRuby >= 1.5.6). No se conocen problemas con
- librerías de plantillas de terceras partes. Sin embargo, si elegís usar
- JRuby, deberías examinar sus Rack handlers porque el servidor web Thin no es
- soportado actualmente.
+ JRuby es soportado oficialmente (JRuby >= 1.6.0). No se conocen
+ problemas con librerías de plantillas de terceras partes. Sin
+ embargo, si elegís usar JRuby, deberías examinar sus Rack handlers
+ porque el servidor web Thin no es soportado completamente. El
+ soporte de JRuby para extensiones C se encuentra en una etapa
+ experimental, sin embargo, de momento solo RDiscount se ve afectada.
Siempre le prestamos atención a las nuevas versiones de Ruby.
Las siguientes implementaciones de Ruby no se encuentran soportadas
oficialmente. De cualquier manera, pueden ejecutar Sinatra:
* Versiones anteriores de JRuby y Rubinius
-* MacRuby
-* Maglev
-* IronRuby
+* MacRuby, Maglev e IronRuby
* Ruby 1.9.0 y 1.9.1
No estar soportada oficialmente, significa que si las cosas solamente se rompen
ahí y no en una plataforma soportada, asumimos que no es nuestro problema sino
el suyo.
+Nuestro servidor CI también se ejecuta sobre ruby-head (que será la
+próxima versión 1.9.3). Como está en movimiento constante, no podemos
+garantizar nada. De todas formas, podés contar con que 1.9.3-p0 sea
+soportada.
+
Sinatra debería funcionar en cualquier sistema operativo soportado por la
implementación de Ruby elegida.

0 comments on commit e68e219

Please sign in to comment.