Skip to content
Browse files

skip temple 0.3.3

  • Loading branch information...
1 parent d303ced commit f40e43d2b09ebdfa59311a7a85e5548a5759b9f5 @rkh rkh committed
Showing with 1 addition and 0 deletions.
  1. +1 −0 Gemfile
View
1 Gemfile
@@ -38,6 +38,7 @@ else
end
gem 'slim', '~> 1.0'
+gem 'temple', '!= 0.3.3'
gem 'RedCloth' if RUBY_VERSION < "1.9.3" and not RUBY_ENGINE.start_with? 'ma'
gem 'coffee-script', '>= 2.0'
gem 'rdoc'

7 comments on commit f40e43d

@minad

Slim 1.0.2 requires 0.3.3

@rkh
Sinatra member

Which means we will run Slim 1.0.1, which is ok for me, too many failures and I'm having a hard time finding docs on how to fix this. Since I'm about to prep a release and am rather busy, I do not have time to care about this now.

@rkh
Sinatra member

Temple 0.3.3 is about to be yanked from rubygems.org

@minad

Do you have failures with Slim 1.0.2? This is interesting because we will release Slim 1.0.3 which will require temple 0.3.4.

@rkh
Sinatra member

I'm really disappointed by Slim not following Semantic Versioning.

@minad

Slim 1.0.2 will be backward-compatible with 1.0.0 if temple 0.3.4 is used. Since temple 0.3.3 will be yanked this won't be a problem then. We will take care that semver is followed in future releases.

Please sign in to comment.
Something went wrong with that request. Please try again.