New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rails 5.0/ Ruby 2.3.0 Compatibility #1071

Closed
Harishkris opened this Issue Jan 20, 2016 · 3 comments

Comments

Projects
None yet
4 participants
@Harishkris

Harishkris commented Jan 20, 2016

I am trying to install the latest version of sinatra gem in my rails app( ruby version 2.3.0, rails version 5.0.0.beta1). It installs sinatra-1.0 when no version is specified, but when i specify version, say 1.4.6, it says

Bundler could not find compatible versions for gem "rack":
In snapshot (Gemfile.lock):
rack (= 2.0.0.alpha)

In Gemfile:
rails (< 5.1, >= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
railties (= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
actionpack (= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
rack (~> 2.x)

rails (< 5.1, >= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
  railties (= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
    actionpack (= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
      rack-test (~> 0.6.3) was resolved to 0.6.3, which depends on
        rack (>= 1.0)

rails (< 5.1, >= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
  railties (= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
    actionpack (= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
      rack-test (~> 0.6.3) was resolved to 0.6.3, which depends on
        rack (>= 1.0)

sinatra (= 1.4.6) was resolved to 1.4.6, which depends on
  rack (~> 1.4)

rails (< 5.1, >= 5.0.0.beta1) was resolved to 5.0.0.beta1, which depends on
  sprockets-rails (>= 2.0.0) was resolved to 3.0.0, which depends on
    sprockets (>= 3.0.0) was resolved to 3.5.2, which depends on
      rack (< 3, > 1)
@kgrz

This comment has been minimized.

Show comment
Hide comment
@kgrz

kgrz Jan 20, 2016

Member

Please use the branch 2.2.0-alpha in your Gemfile for sinatra. We are working on a new release for Sinatra 2.0. Until that time, this fix should work.

gem 'sinatra', github: 'sinatra/sinatra', branch: '2.2.0-alpha'

Suboptimal, but should work. Ongoing discussion about this previously-reported problem is here: #1055

Member

kgrz commented Jan 20, 2016

Please use the branch 2.2.0-alpha in your Gemfile for sinatra. We are working on a new release for Sinatra 2.0. Until that time, this fix should work.

gem 'sinatra', github: 'sinatra/sinatra', branch: '2.2.0-alpha'

Suboptimal, but should work. Ongoing discussion about this previously-reported problem is here: #1055

@kgrz kgrz closed this Jan 20, 2016

@lesliev

This comment has been minimized.

Show comment
Hide comment
@lesliev

lesliev Mar 15, 2016

This branch doesn't seem to exist any more. Has Sinatra 2 moved to some other repo?

lesliev commented Mar 15, 2016

This branch doesn't seem to exist any more. Has Sinatra 2 moved to some other repo?

@zzak

This comment has been minimized.

Show comment
Hide comment
@zzak

zzak Mar 15, 2016

Member

@lesliev You can use the master branch now

Member

zzak commented Mar 15, 2016

@lesliev You can use the master branch now

@b264 b264 referenced this issue Jun 24, 2016

Closed

New Release #1123

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment