New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Could not find gem 'rack-protection (~> 2.0)', which is required by gem 'sinatra', in any of the sources. #1149

Closed
salmagomaa opened this Issue Jul 25, 2016 · 2 comments

Comments

Projects
None yet
2 participants
@salmagomaa

salmagomaa commented Jul 25, 2016

I was working with sinatra master since my upgrading to Rails 5, but today it seems there are some updates to the master, that throws the following error when I am trying to update the bundle.

The thrown error is:

Bundler could not find compatible versions for gem "rack-protection":
In Gemfile:
sinatra was resolved to 2.0.0.pre.alpha, which depends on
rack-protection (~> 2.0)

Could not find gem 'rack-protection (~> 2.0)', which is required by gem
'sinatra', in any of the sources.

Any help please?

@tloszko

This comment has been minimized.

Show comment
Hide comment
@tloszko

tloszko Jul 25, 2016

Use github's version:

gem "rack-protection", :github => "sinatra/rack-protection"

tloszko commented Jul 25, 2016

Use github's version:

gem "rack-protection", :github => "sinatra/rack-protection"

@salmagomaa

This comment has been minimized.

Show comment
Hide comment
@salmagomaa

salmagomaa Jul 25, 2016

Thanks a million! It works for me.

salmagomaa commented Jul 25, 2016

Thanks a million! It works for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment