require rack >= 1.1 #26

Closed
rkh opened this Issue May 30, 2010 · 4 comments

Comments

Projects
None yet
2 participants
Owner

rkh commented May 30, 2010

There is some rack 1.0 legacy code that could be removed. Rails switched with 2.3.6 – it's at 2.3.9/3.0.0 now ;) – from 1.0 to 1.1, so I don't see a reason Sinatra shouldn't.

Member

cschneid commented Sep 16, 2010

If I remember right, rack 1.1+ doesn't work with ruby 1.8.6. I'd have verify that though.

Owner

rkh commented Sep 16, 2010

No, that's 1.2+, 1.1.0 works perfectly fine on 1.8.6.

Owner

rkh commented Oct 9, 2010

Require at least Rack 1.1.0. Closed by 89af8c1.

Owner

rkh commented Oct 9, 2010

done.

@7stud 7stud pushed a commit to 7stud/sinatra that referenced this issue Aug 27, 2014

@Syd Syd Merged pull request #26 from pcapr/master.
Adding us to Sinatra in the wild
90d6e79

@zzak zzak pushed a commit to zzak/sinatra that referenced this issue Jul 22, 2016

@rkh rkh Merge pull request #26 from licensetoil/master
content_for? method
706d023

@zzak zzak pushed a commit to zzak/sinatra that referenced this issue Jul 22, 2016

@rkh rkh Merge pull request #26 from licensetoil/master
content_for? method
3cfef30

@zzak zzak pushed a commit that referenced this issue Aug 12, 2016

@rkh rkh Merge pull request #26 from send/x-content-type-options
X-Content-Type-Options feature
47c9f73

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment