Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Source maps cannot be loaded by Chrome DevTools #17

Open
d3lm opened this issue Aug 13, 2019 · 2 comments

Comments

@d3lm
Copy link

commented Aug 13, 2019

Issuehunt badges

When I am serving a specific directory the devtools always complain that the source maps couldn't be loaded. That also makes sense cause Chrome will try to fetch those relative to directory that is served, meaning it looks for source maps in app://-/Users/... and obviously it cannot find them there, cause that path is not a correct path to the node modules where the source maps are located. Any idea what I could do to fix this?


IssueHunt Summary

Backers (Total: $40.00)

Become a backer now!

Or submit a pull request to get the deposits!

Tips


IssueHunt has been backed by the following sponsors. Become a sponsor

@issuehunt-app

This comment has been minimized.

Copy link

commented Sep 9, 2019

@issuehunt has funded $40.00 to this issue.


@dedo1911

This comment has been minimized.

Copy link
Contributor

commented Sep 9, 2019

Can you please provide more context of what you're trying to do and what's your folder structure?

In my application, I'm using create-react-app and source maps are included in the build output folder. When I point electron-serve to the build output directory everything works fine and sources are mapped correctly in the devtools.

If I've understood correctly, you want to add another folder in the config where to search for source maps. Is that right?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.