Permalink
Browse files

meta tweaks

  • Loading branch information...
1 parent a200d9e commit 7bf6c1c171ca0a4085d43c936a67c185f8121982 @sindresorhus committed Apr 7, 2016
Showing with 13 additions and 29 deletions.
  1. +1 −5 .editorconfig
  2. +0 −16 .jshintrc
  3. +10 −6 package.json
  4. +2 −2 readme.md
View
@@ -1,4 +1,3 @@
-# editorconfig.org
root = true
[*]
@@ -8,9 +7,6 @@ charset = utf-8
trim_trailing_whitespace = true
insert_final_newline = true
-[package.json]
+[{package.json,*.yml}]
indent_style = space
indent_size = 2
-
-[*.md]
-trim_trailing_whitespace = false
View
@@ -1,16 +0,0 @@
-{
- "node": true,
- "esnext": true,
- "bitwise": true,
- "camelcase": true,
- "curly": true,
- "eqeqeq": true,
- "immed": true,
- "indent": 4,
- "newcap": true,
- "noarg": true,
- "quotmark": "single",
- "undef": true,
- "unused": "vars",
- "strict": true
-}
View
@@ -7,13 +7,13 @@
"author": {
"name": "Sindre Sorhus",
"email": "sindresorhus@gmail.com",
- "url": "http://sindresorhus.com"
+ "url": "sindresorhus.com"
},
"engines": {
"node": ">=0.10.0"
},
"scripts": {
- "test": "grunt"
+ "test": "xo && grunt"
},
"files": [
"tasks"
@@ -35,9 +35,13 @@
"object-assign": "^4.0.1"
},
"devDependencies": {
- "grunt": "^0.4.5",
- "grunt-cli": "^0.1.13",
- "grunt-contrib-clean": "^0.6.0",
- "grunt-contrib-nodeunit": "^0.4.1"
+ "grunt": "^1.0.1",
+ "grunt-cli": "^1.2.0",
+ "grunt-contrib-clean": "^1.0.0",
+ "grunt-contrib-nodeunit": "^1.0.0",
+ "xo": "*"
+ },
+ "peerDependencies": {
+ "grunt": ">=0.4.0"
}
}
View
@@ -6,7 +6,7 @@
*The issue tracker is disabled because of continuous abuse. Use [Stack Overflow](https://stackoverflow.com/questions/tagged/node-sass) for support questions. Issues with the output should be reported on the libsass [issue tracker](https://github.com/hcatlin/libsass/issues). Install issues should be reported on the node-sass [issue tracker](https://github.com/sass/node-sass/issues). Learn how [semver works](https://nodesource.com/blog/semver-tilde-and-caret) before opening a PR updating node-sass.*
-This task uses [libsass](http://libsass.org), which is a Sass compiler in C++. It's a lot faster than the original Ruby compiler and [fully compatible](http://sass-compatibility.github.io/).
+This task uses [libsass](http://libsass.org), which is a Sass compiler in C++. It's a lot faster than the original Ruby compiler and [fully compatible](http://sass-compatibility.github.io/).
## Install
@@ -49,4 +49,4 @@ The default value for the `precision` option is `10`, so you don't have to chang
## License
-MIT © [Sindre Sorhus](http://sindresorhus.com)
+MIT © [Sindre Sorhus](https://sindresorhus.com)

0 comments on commit 7bf6c1c

Please sign in to comment.