New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm install -g harp on windows 7 error #425

Closed
MakiMark opened this Issue Mar 16, 2015 · 5 comments

Comments

Projects
None yet
6 participants
@MakiMark

MakiMark commented Mar 16, 2015

I have everything installed on my windows maschine: (ruby, compass and nodejs) and now I wanted to install the local webserver harp but i get the following errors (Please see pic below) can someone please help? Thanks a lot.

error

@silentrob

This comment has been minimized.

Show comment
Hide comment
@silentrob

silentrob Mar 16, 2015

Collaborator

This might sound like a crazy question, but where you online when you ran that command? It looks like you were unable to connect to github.com to pull in the remote repo.

Collaborator

silentrob commented Mar 16, 2015

This might sound like a crazy question, but where you online when you ran that command? It looks like you were unable to connect to github.com to pull in the remote repo.

@btkarthick

This comment has been minimized.

Show comment
Hide comment
@btkarthick

btkarthick Apr 9, 2015

I am also getting exactly the same error!!!

harp-install-error

btkarthick commented Apr 9, 2015

I am also getting exactly the same error!!!

harp-install-error

@kennethormandy

This comment has been minimized.

Show comment
Hide comment
@kennethormandy

kennethormandy Apr 9, 2015

Collaborator

Ah I think the problem might be with using the GitHub URLs for dependencies when GitHub is down. We should be able to fix this to some degree. If you try the same thing again later on it should work.

Collaborator

kennethormandy commented Apr 9, 2015

Ah I think the problem might be with using the GitHub URLs for dependencies when GitHub is down. We should be able to fix this to some degree. If you try the same thing again later on it should work.

@dogancelik

This comment has been minimized.

Show comment
Hide comment
@dogancelik

dogancelik Apr 28, 2015

@MakiMark, @btkarthick
This problem can be fixed by installing MsysGit and cleaning %appdata%\npm-cache.
Make sure git is in PATH.
(FYI: I had the same problem, the problem was Git was not installed)

dogancelik commented Apr 28, 2015

@MakiMark, @btkarthick
This problem can be fixed by installing MsysGit and cleaning %appdata%\npm-cache.
Make sure git is in PATH.
(FYI: I had the same problem, the problem was Git was not installed)

@ksaff

This comment has been minimized.

Show comment
Hide comment
@ksaff

ksaff Jul 31, 2015

I encountered the same issue. Git must use a port that's blocked by the firewall I'm behind, as replacing git:// with https:// allowed me to clone the repo. Can this be changed somewhere?

Edit:
Looks like the first dependency for harp, terraform, has jade and minify dependencies specified with git:// URLs.

...which was fixed in that terraform commit (64915d3), and apparently was never merged in, since it still shows up with git:// URLs in terraform's package.json.

ksaff commented Jul 31, 2015

I encountered the same issue. Git must use a port that's blocked by the firewall I'm behind, as replacing git:// with https:// allowed me to clone the repo. Can this be changed somewhere?

Edit:
Looks like the first dependency for harp, terraform, has jade and minify dependencies specified with git:// URLs.

...which was fixed in that terraform commit (64915d3), and apparently was never merged in, since it still shows up with git:// URLs in terraform's package.json.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment