New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Posible Solucion - Mal funcionamiento de la VM en Winsows 8 #1007

Closed
jazcarate opened this Issue Apr 15, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@jazcarate
Copy link
Member

jazcarate commented Apr 15, 2018

@GastonTS tenía un post en campusvirtual que algunos alumnos (@SfaraLucas ) no estaban pudiendo ver, así que hago el replay acá en el foro:

Hola, las ultimas semanas estuve renegando con la maquina virtual, ya que tardaba mucho en levantar, o cuando lo hacia andaba lenta, y terminaba entorpeciéndome en todo lo que quería hacer. Luego de buscar un poco y no llegar a una solución, acudí a la ayuda de Matías, que por suerte fue un poco mas atento que yo y encontró este thread en los foros de virtualBox: https://forums.virtualbox.org/viewtopic.php?f=6&t=57686

Cuestión, en ese thread el muchacho presentaba un problema similar, la maquina virtual le andaba lento sin importar lo que hiciera. Luego de algunas respuestas sin llegar a buen puerto alguien le pregunta si tenia el Hyper V activado, y su respuesta es que sí.
Ahora, ¿Qué es el Hyper V? Es un programa de virtualización que usa Windows, que según comentan en la discusión no permite a otros acceder a VMX. Por lo que la virtualBox no puede hacer su trabajo en paz.

La solución que ofrecen es deshabilitarlo o hacer que no se inicie con la maquina. En mi caso me pareció mejor deshabilitarlo, ya que además no lo uso (en mi caso, lo obtuve instalando el Visual Studio 2013, pero tengo entendido que algunos servicios de Windows también lo instalan). Una vez deshabilitado probé la VM y no solo abría y funcionaba bien sino que lo hacia rápido y sin ningún problema (aunque sea por ahora).

Bueno, si les anda mal, o lenta la VM en Windows 8 quizás este no sea su problema, pero quizás si... Si este es el caso, acá hay una mini guía de como deshabilitarlo (es una característica de Windows se desactiva como cualquier otra, no es la gran cosa).

1- Entro al panel de control, luego a Programas y accedo a "Activar o desactivar las características de Windows"
image

2- Me pide que aguarde un momento mientras carga la lista, una vez cargada busco Hyper V y saco lo deshabilito (como en la imagen).
image

3- Les pide que reinicien, lo hacen. Una vez que esta prendida devuelta, abren la VM y listo, debería andar bien.

Bueno, a mi me funciono en 2 PCs (a pesar de que en una ya había instalado Linux, en la notebook se me complicaba). Si les sirvió bien y si no, bueno aunque sea aporto por si a alguno le pasa lo mismo.

Saludos!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment