Permalink
Browse files

Problem: Rust 1.29 is outdated

Solution: use 1.30 for builds
  • Loading branch information...
yrashk committed Nov 1, 2018
1 parent fb7e4ee commit 8bc2d4698b7beaa4643c8fcd685a8ac536567957
Showing with 3 additions and 3 deletions.
  1. +1 −1 README.md
  2. +1 −1 build-tools/cross-compile-osx/Dockerfile
  3. +1 −1 build-tools/linux-build-container/Dockerfile
@@ -110,7 +110,7 @@ build SIT from sources.*
As SIT is currently in its early days, sometimes it might make sense to use a
pre-release build. We encourage that. It helps us building a better product.
Firstly, you will need to install Rust 1.28 and CMake. Luckily
Firstly, you will need to install Rust 1.30 and CMake. Luckily
it is typically a very simple process. You can find
instructions on [Rust's website](https://www.rust-lang.org/en-US/install.html).
@@ -1,4 +1,4 @@
FROM rust:1.29
FROM rust:1.30
RUN apt-get update && apt-get install -y clang autotools-dev automake cmake libfuse-dev fuse git
RUN rustup target add x86_64-apple-darwin
RUN git clone https://github.com/tpoechtrager/osxcross && cd osxcross && git checkout 1a1733a
@@ -1,4 +1,4 @@
FROM rust:1.29
FROM rust:1.30
RUN apt-get update && apt-get install -y cmake libgit2-dev musl-tools
RUN rustup target add x86_64-unknown-linux-musl
RUN apt-get install -y clang libclang-dev

0 comments on commit 8bc2d46

Please sign in to comment.