Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Adding bundler

  • Loading branch information...
commit ae73525a5fa034afed426f42387f4440bf27889a 1 parent bcabebd
@jmazzi jmazzi authored
View
15 Gemfile
@@ -1,13 +1,4 @@
-source 'http://rubygems.org'
-gem 'xml-simple'
+source "http://rubygems.org"
-group :development, :test do
- gem 'redgreen'
- gem 'jeweler'
- gem 'fakeweb'
- gem 'turn'
-end
-
-platforms :jruby do
- gem 'jruby-openssl'
-end
+# Specify your gem's dependencies in lol.gemspec
+gemspec
View
29 Rakefile
@@ -1,31 +1,6 @@
require 'rubygems'
require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "solusvm"
- gem.summary = "Wrapper for the SolusVM Admin::API"
- gem.description = "Solusvm allows for easy interaction with the SolusVM Admin::API."
- gem.email = "jmazzi@gmail.com"
- gem.homepage = "http://www.site5.com"
- gem.authors = ["Justin Mazzi"]
- gem.add_dependency 'xml-simple'
- gem.add_dependency 'jruby-openssl' if RUBY_PLATFORM == 'java'
- gem.add_development_dependency 'redgreen'
- gem.add_development_dependency 'fakeweb'
- gem.add_development_dependency 'rake', '~> 0.8.7'
- gem.rubyforge_project = 'solusvm'
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
-
- Jeweler::RubyforgeTasks.new do |rubyforge|
- rubyforge.doc_task = "rdoc"
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
-end
+require 'bundler/gem_tasks'
require 'rake/testtask'
@@ -51,7 +26,7 @@ end
begin
require 'rdoc/task'
Rake::RDocTask.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
+ version = Solusvm::VERSION
rdoc.rdoc_dir = 'rdoc'
rdoc.title = "solusvm #{version}"
View
5 VERSION.yml
@@ -1,5 +0,0 @@
----
-:patch: 1
-:build:
-:major: 0
-:minor: 8
View
3  lib/solusvm/version.rb
@@ -0,0 +1,3 @@
+module Solusvm
+ VERSION = "0.8.1"
+end
View
134 solusvm.gemspec
@@ -1,120 +1,28 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "solusvm/version"
Gem::Specification.new do |s|
- s.name = %q{solusvm}
- s.version = "0.8.1"
+ s.name = %q{solusvm}
+ s.version = Solusvm::VERSION
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Justin Mazzi"]
- s.date = %q{2011-09-09}
- s.default_executable = %q{solusvm}
- s.description = %q{Solusvm allows for easy interaction with the SolusVM Admin::API.}
- s.email = %q{jmazzi@gmail.com}
- s.executables = ["solusvm"]
- s.extra_rdoc_files = [
- "LICENSE",
- "README.markdown"
- ]
- s.files = [
- ".document",
- ".rbenv-version",
- ".rvmrc",
- ".travis.yml",
- "Gemfile",
- "LICENSE",
- "README.markdown",
- "Rakefile",
- "VERSION.yml",
- "bin/solusvm",
- "lib/solusvm.rb",
- "lib/solusvm/base.rb",
- "lib/solusvm/client.rb",
- "lib/solusvm/exceptions.rb",
- "lib/solusvm/general.rb",
- "lib/solusvm/hash.rb",
- "lib/solusvm/server.rb",
- "solusvm.gemspec",
- "test/fixtures/base_bad_key.txt",
- "test/fixtures/base_node_does_not_exist.txt",
- "test/fixtures/base_unauthorized_ip.txt",
- "test/fixtures/client_authenticate_error.txt",
- "test/fixtures/client_authenticate_success.txt",
- "test/fixtures/client_change_password_error.txt",
- "test/fixtures/client_change_password_success.txt",
- "test/fixtures/client_create_error.txt",
- "test/fixtures/client_create_success.txt",
- "test/fixtures/client_exists_success.txt",
- "test/fixtures/error.txt",
- "test/fixtures/general_node_list_all_ips_available.txt",
- "test/fixtures/general_node_list_all_ips_not_available.txt",
- "test/fixtures/general_node_statistics_success.txt",
- "test/fixtures/general_nodes_success.txt",
- "test/fixtures/general_templates_success.txt",
- "test/fixtures/server_boot_success.txt",
- "test/fixtures/server_change_success.txt",
- "test/fixtures/server_create_success.txt",
- "test/fixtures/server_exists_success.txt",
- "test/fixtures/server_info_success.txt",
- "test/fixtures/server_infoall_success.txt",
- "test/fixtures/server_reboot_success.txt",
- "test/fixtures/server_resume_success.txt",
- "test/fixtures/server_shutdown_success.txt",
- "test/fixtures/server_suspend_success.txt",
- "test/fixtures/server_terminate_success.txt",
- "test/helper.rb",
- "test/test_base.rb",
- "test/test_client.rb",
- "test/test_general.rb",
- "test/test_hash.rb",
- "test/test_server.rb",
- "test/test_solusvm.rb"
- ]
- s.homepage = %q{http://www.site5.com}
- s.require_paths = ["lib"]
- s.rubyforge_project = %q{solusvm}
- s.rubygems_version = %q{1.6.2}
- s.summary = %q{Wrapper for the SolusVM Admin::API}
+ s.authors = ["Justin Mazzi"]
+ s.email = ["jmazzi@gmail.com"]
+ s.homepage = "http://www.site5.com"
+ s.summary = "Wrapper for the SolusVM Admin::API"
+ s.description = "Solusvm allows for easy interaction with the SolusVM Admin::API."
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ s.rubyforge_project = "solusvm"
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<xml-simple>, [">= 0"])
- s.add_runtime_dependency(%q<jruby-openssl>, [">= 0"]) if RUBY_PLATFORM == 'java'
- s.add_development_dependency(%q<redgreen>, [">= 0"])
- s.add_development_dependency(%q<jeweler>, [">= 0"])
- s.add_development_dependency(%q<fakeweb>, [">= 0"])
- s.add_development_dependency(%q<turn>, [">= 0"])
- s.add_runtime_dependency(%q<xml-simple>, [">= 0"])
- s.add_development_dependency(%q<redgreen>, [">= 0"])
- s.add_development_dependency(%q<fakeweb>, [">= 0"])
- s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
- else
- s.add_dependency(%q<xml-simple>, [">= 0"])
- s.add_dependency(%q<jruby-openssl>, [">= 0"]) if RUBY_PLATFORM == 'java'
- s.add_dependency(%q<redgreen>, [">= 0"])
- s.add_dependency(%q<jeweler>, [">= 0"])
- s.add_dependency(%q<fakeweb>, [">= 0"])
- s.add_dependency(%q<turn>, [">= 0"])
- s.add_dependency(%q<xml-simple>, [">= 0"])
- s.add_dependency(%q<redgreen>, [">= 0"])
- s.add_dependency(%q<fakeweb>, [">= 0"])
- s.add_dependency(%q<rake>, ["~> 0.8.7"])
- end
- else
- s.add_dependency(%q<xml-simple>, [">= 0"])
- s.add_dependency(%q<jruby-openssl>, [">= 0"]) if RUBY_PLATFORM == 'java'
- s.add_dependency(%q<redgreen>, [">= 0"])
- s.add_dependency(%q<jeweler>, [">= 0"])
- s.add_dependency(%q<fakeweb>, [">= 0"])
- s.add_dependency(%q<turn>, [">= 0"])
- s.add_dependency(%q<xml-simple>, [">= 0"])
- s.add_dependency(%q<redgreen>, [">= 0"])
- s.add_dependency(%q<fakeweb>, [">= 0"])
- s.add_dependency(%q<rake>, ["~> 0.8.7"])
- end
-end
+ s.add_runtime_dependency 'xml-simple'
+ s.add_runtime_dependency 'jruby-openssl' if RUBY_PLATFORM == 'java'
+ s.add_development_dependency 'redgreen'
+ s.add_development_dependency 'fakeweb'
+ s.add_development_dependency 'turn'
+ s.add_development_dependency 'rake', '~> 0.8.7'
+end
Please sign in to comment.
Something went wrong with that request. Please try again.