Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Layout Block Removed: Conflict with WPSSO Core #677

Closed
Misplon opened this issue Jun 13, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@Misplon
Copy link
Member

commented Jun 13, 2019

To replicate, activate https://wordpress.org/plugins/wpsso/.
Create a Block Editor page.
Check the Console. The Layout Block is missing.

Uncaught SyntaxError: Identifier 'RawHTML' has already been declared at siteorigin-panels-layout-block.js?ver=dev:1

@braamgenis

This comment has been minimized.

Copy link
Member

commented Jun 20, 2019

This is being caused by wpsso using const to declare a RawHTML variable in the global scope. Then the error occurs when our block tries to redeclare RawHTML as a var. const doesn't allow an identifier to be reused if it already exists in a scope, where var does. Blocks, like the Layout Block, which are compiled using something like Babel would have their global const declarations converted to var, so this conflict won't occur between the Layout Block and other blocks, but it likely will occur between WPSSO and other blocks.

@Misplon Misplon changed the title Layout Block Removed: Conflict with WSSO Core Layout Block Removed: Conflict with WPSSO Core Jun 21, 2019

@Misplon

This comment has been minimized.

Copy link
Member Author

commented Jun 21, 2019

I've updated the reporting thread: https://siteorigin.com/thread/wpsso-plugin-not-compatible/. Thanks Braam.

@Misplon Misplon closed this Jun 21, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.