Permalink
Browse files

correct gemspec

  • Loading branch information...
1 parent bc6d97a commit 2c9ad9d5acf82fa1b0c373bf05c8e7753e221b13 @siuying committed Apr 19, 2012
Showing with 67 additions and 11 deletions.
  1. +5 −2 Manifest
  2. +11 −8 Rakefile
  3. +50 −0 instant.gemspec
  4. +1 −1 lib/instant/version.rb
View
@@ -1,12 +1,15 @@
Gemfile
+Manifest
Procfile
README.md
Rakefile
+config.ru
instant.gemspec
lib/instant.rb
lib/instant/context.rb
lib/instant/processor.rb
lib/instant/runner.rb
-lib/instant/sinatra/app.rb
lib/instant/version.rb
-Manifest
+spec/instant/context_spec.rb
+spec/instant/processor_spec.rb
+spec/instant/runner_spec.rb
View
@@ -1,14 +1,17 @@
+$LOAD_PATH << "lib"
+require 'instant/version'
require 'rubygems'
require 'rake'
require 'echoe'
-Echoe.new('instant', '0.0.1') do |p|
- p.description = "Generate a unique token with Active Record."
- p.url = "http://github.com/ryanb/uniquify"
- p.author = "Ryan Bates"
- p.email = "ryan@railscasts.com"
- p.ignore_pattern = ["tmp/*", "script/*"]
- p.development_dependencies = []
+Echoe.new('instant', Instant::VERSION) do |p|
+ p.description = "An experiment on real time visualize development tool."
+ p.url = "http://github.com/siuying/instant"
+ p.author = "Francis Chong"
+ p.email = "francis@ignition.hk"
+ p.ignore_pattern = ["pkg/*", "spec/*", "views/*", "public/**/*", "lib/instant/sinatra/*"]
+ p.development_dependencies = ["rspec ~>2.9.0", "rake ~>1.1", "echoe", "autotest", "pry"]
+ p.runtime_dependencies = ['ruby2ruby ~>1.3.1', 'ruby_parser ~>2.3.1']
end
-Dir["#{File.dirname(__FILE__)}/tasks/*.rake"].sort.each { |ext| load ext }
+Dir["#{File.dirname(__FILE__)}/tasks/*.rake"].sort.each { |ext| load ext }
View
@@ -0,0 +1,50 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = "instant"
+ s.version = "0.0.2"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Francis Chong"]
+ s.date = "2012-04-19"
+ s.description = "An experiment on real time visualize development tool."
+ s.email = "francis@ignition.hk"
+ s.extra_rdoc_files = ["README.md", "lib/instant.rb", "lib/instant/context.rb", "lib/instant/processor.rb", "lib/instant/runner.rb", "lib/instant/version.rb"]
+ s.files = ["Gemfile", "Manifest", "Procfile", "README.md", "Rakefile", "config.ru", "instant.gemspec", "lib/instant.rb", "lib/instant/context.rb", "lib/instant/processor.rb", "lib/instant/runner.rb", "lib/instant/version.rb", "spec/instant/context_spec.rb", "spec/instant/processor_spec.rb", "spec/instant/runner_spec.rb"]
+ s.homepage = "http://github.com/siuying/instant"
+ s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "Instant", "--main", "README.md"]
+ s.require_paths = ["lib"]
+ s.rubyforge_project = "instant"
+ s.rubygems_version = "1.8.15"
+ s.summary = "An experiment on real time visualize development tool."
+
+ if s.respond_to? :specification_version then
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<ruby2ruby>, ["~> 1.3.1"])
+ s.add_runtime_dependency(%q<ruby_parser>, ["~> 2.3.1"])
+ s.add_development_dependency(%q<rspec>, ["~> 2.9.0"])
+ s.add_development_dependency(%q<rake>, ["~> 1.1"])
+ s.add_development_dependency(%q<echoe>, [">= 0"])
+ s.add_development_dependency(%q<autotest>, [">= 0"])
+ s.add_development_dependency(%q<pry>, [">= 0"])
+ else
+ s.add_dependency(%q<ruby2ruby>, ["~> 1.3.1"])
+ s.add_dependency(%q<ruby_parser>, ["~> 2.3.1"])
+ s.add_dependency(%q<rspec>, ["~> 2.9.0"])
+ s.add_dependency(%q<rake>, ["~> 1.1"])
+ s.add_dependency(%q<echoe>, [">= 0"])
+ s.add_dependency(%q<autotest>, [">= 0"])
+ s.add_dependency(%q<pry>, [">= 0"])
+ end
+ else
+ s.add_dependency(%q<ruby2ruby>, ["~> 1.3.1"])
+ s.add_dependency(%q<ruby_parser>, ["~> 2.3.1"])
+ s.add_dependency(%q<rspec>, ["~> 2.9.0"])
+ s.add_dependency(%q<rake>, ["~> 1.1"])
+ s.add_dependency(%q<echoe>, [">= 0"])
+ s.add_dependency(%q<autotest>, [">= 0"])
+ s.add_dependency(%q<pry>, [">= 0"])
+ end
+end
View
@@ -1,3 +1,3 @@
module Instant
- VERSION = "0.0.1"
+ VERSION = "0.0.2"
end

0 comments on commit 2c9ad9d

Please sign in to comment.