Permalink
Browse files

updated for RubyMotion 1.25 (with define_method)

  • Loading branch information...
1 parent 98fd6b1 commit 3f8278e373661bb11bfa9d965b499887236d98ea @siuying committed Oct 6, 2012
Showing with 7 additions and 7 deletions.
  1. +2 −0 README.md
  2. +3 −1 Rakefile
  3. +1 −4 lib/motion-stump.rb
  4. +1 −1 lib/stump/version.rb
  5. +0 −1 motion-stump.gemspec
View
@@ -39,6 +39,8 @@ my_mock.hello # => "what fun is this?"
## Installation
+**Requires RubyMotion 1.25**
+
```ruby
gem install 'motion-stump'
```
View
@@ -2,9 +2,11 @@
require "bundler/gem_tasks"
$:.unshift("/Library/RubyMotion/lib")
+
require 'motion/project'
require 'bundler'
-Bundler.require :default, :development
+Bundler.setup :default, :development
+require 'motion-stump'
Motion::Project::App.setup do |app|
app.name = 'motion-stump'
View
@@ -26,7 +26,4 @@ def spec_files
File.join(File.dirname(__FILE__), 'stump/proxy.rb')
].reverse.each {|f| app.files.unshift(f) }
end
-end
-
-## Include supports for define_method
-require 'motion-define-method'
+end
@@ -1,3 +1,3 @@
module Stump
- VERSION = "0.1.2"
+ VERSION = "0.2.0"
end
@@ -13,7 +13,6 @@ Gem::Specification.new do |gem|
gem.require_paths = ["lib"]
gem.version = Stump::VERSION
- gem.add_dependency 'motion-define-method', '~> 0.1.2'
gem.add_development_dependency 'motion-redgreen', '~> 0.1.0'
gem.add_development_dependency 'rake'
end

0 comments on commit 3f8278e

Please sign in to comment.