No description, website, or topics provided.
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
BQMM_Lib
gradle/wrapper
leanchat
leanchatlib-demo
leanchatlib
libs
.gitignore
README.md
build.gradle
gradlew
gradlew.bat
import-summary.txt
settings.gradle

README.md

LeanChat Android 客户端

简介

这个示例项目全面展示了 LeanCloud 实时通讯功能的应用,该版本集成了表情 mm SDK(表情mm SDK是上海似颜绘科技有限公司提供的表情商店SDK, 开发者可以利用此SDK集成丰富的表情。 )帮助用户在使用实时通信服务的同时,更方便的加入表情功能。

效果

表情 mm

下载

请直接点击 Github 上的Download Zip,如图所示,这样只下载最新版本。如果是 git clone,则可能非常慢,因为含杂很大的提交历史。某次测试两者是1.5M:40M。

qq20150618-2 2x

LeanChat Android 项目构成

  • leanchatlib,核心的聊天逻辑和聊天界面库。有了它,可以快速集成聊天功能,支持文字、音频、图片、表情消息,消息通知。同时也有相应的 iOS版本
  • leancahtlib-demo,leanchatlib 最简单的使用例子。可以看到配置一下 AndroidManifest,以及额外配置一下 user 信息,即可集成聊天,不管是用 LeanCloud 的用户系统还是自己的用户系统。
  • leanchat ,为整个聊天应用。它包含好友管理、群组管理、地理消息、附近的人、个人页面、登录注册的功能,完全基于 LeanCloud 的存储和通信功能。

LeanChat 项目构成

Eclipse 或 Intellij IDEA 运行需知

  1. 请装相应的 Gradle 插件
  2. Intellij IDEA 用户建议装 Android Studio,AS 是基于 IDEA 的,不仅有和 IDEA 一样的体验,还是官方推荐的 IDE。
  3. 用到了 ButterKnife 开源库,Eclipse需要设置一下来支持 ButterKnife 的注解,具体如何设置见 http://jakewharton.github.io/butterknife/ide-eclipse.html 。否则会因为 view 没有绑定上,导致崩溃。
  4. 如果不装 Gradle 插件,非要转换成 Ant 格式,注意项目存在依赖关系,leanchat 依赖 leanchatlib,leanchatlib-demo 也依赖 leanchatlib,建议,先转换 leanchatlib 为 Ant 格式,再转换 leanchat 和 leanchatlib-demo,同时手工修复一下依赖和编译错误。

如何集成 leanchatlib

  1. 请运行 leanchatlib-demo ,看这段代码配置,提供一个UserInfo对象即可,完全不需要AVUser。

相关文档

依赖组件

LeanChat Android 客户端依赖 LeanCloud Android SDK 如下组件:

  • 基础模块
  • 实时通信模块
  • 统计模块

如果需要这些模块 SDK,可以到 这里 下载或者像项目里用 Gradle 方式引入。

技术支持

关于此项目遇到的问题可提 issue