Permalink
Browse files

removed outdated ebuilds of dev-python/setuptools via auto-sync

  • Loading branch information...
1 parent 4e45529 commit 189a30796505c77658a7f187d97119e4dbc31d62 @ahuemer ahuemer committed Mar 26, 2011
@@ -1,47 +0,0 @@
---- distribute_setup.py
-+++ distribute_setup.py
-@@ -78,11 +78,11 @@
- except ImportError:
- return do_download()
- try:
-- pkg_resources.require("distribute>="+version); return
-+ pkg_resources.require("setuptools>="+version); return
- except pkg_resources.VersionConflict, e:
- if was_imported:
- print >>sys.stderr, (
-- "The required version of distribute (>=%s) is not available, and\n"
-+ "The required version of setuptools (>=%s) is not available, and\n"
- "can't be installed while this script is running. Please install\n"
- " a more recent version first, using 'easy_install -U distribute'."
- "\n\n(Currently using %r)"
-@@ -116,7 +116,7 @@
- if delay:
- log.warn("""
- ---------------------------------------------------------------------------
--This script requires distribute version %s to run (even to display
-+This script requires setuptools version %s to run (even to display
- help). I will attempt to download it for you (from
- %s), but
- you may need to enable firewall access for this script first.
---- setup.py
-+++ setup.py
-@@ -21,7 +21,7 @@
- before_install()
-
- dist = setup(
-- name="distribute",
-+ name="setuptools",
- version=VERSION,
- description="Download, build, install, upgrade, and uninstall Python "
- "packages -- easily!",
---- setuptools/package_index.py
-+++ setuptools/package_index.py
-@@ -142,7 +142,7 @@
- yield urlparse.urljoin(url, htmldecode(match.group(1)))
-
- user_agent = "Python-urllib/%s distribute/%s" % (
-- urllib2.__version__, require('distribute')[0].version
-+ urllib2.__version__, require('setuptools')[0].version
- )
-
-
@@ -1,91 +0,0 @@
---- distribute_setup.py
-+++ distribute_setup.py
-@@ -174,12 +174,14 @@
- return open(path).read() == content
-
- def _rename_path(path):
-+ return
- new_name = path + '.OLD.%s' % time.time()
- log.warn('Renaming %s into %s' % (path, new_name))
- os.rename(path, new_name)
- return new_name
-
- def _remove_flat_installation(placeholder):
-+ return
- if not os.path.isdir(placeholder):
- log.warn('Unkown installation at %s' % placeholder)
- return False
-@@ -212,6 +214,7 @@
- return True
-
- def after_install(dist):
-+ return
- log.warn('After install bootstrap.')
- placeholder = dist.get_command_obj('install').install_purelib
- if not os.path.exists(placeholder):
-@@ -256,10 +259,12 @@
- return True
-
- def before_install():
-+ return
- log.warn('Before install bootstrap.')
- fake_setuptools()
-
- def fake_setuptools():
-+ return
- log.warn('Scanning installed packages')
- try:
- import pkg_resources
-@@ -324,52 +329,6 @@
-
- def main(argv, version=DEFAULT_VERSION):
- """Install or upgrade setuptools and EasyInstall"""
-- # let's deactivate any existing setuptools installation first
-- fake_setuptools()
-- try:
-- import setuptools
-- # we need to check if the installed setuptools
-- # is from Distribute or from setuptools
-- if not hasattr(setuptools, '_distribute'):
-- # now we are ready to install distribute
-- raise ImportError
-- except ImportError:
-- egg = None
-- try:
-- egg = download_setuptools(version, delay=0)
-- sys.path.insert(0, egg)
-- import setuptools
-- if not hasattr(setuptools, '_distribute'):
-- placeholder = os.path.split(os.path.dirname(setuptools.__file__))[0]
-- if not placeholder.endswith('.egg'):
-- res = _remove_flat_installation(placeholder)
-- if res:
-- _relaunch()
-- print >> sys.stderr, (
-- "The patch didn't work, Setuptools is still active.\n"
-- "Possible reason: your have a system-wide setuptools installed "
-- "and you are in a virtualenv.\n"
-- "If you are inside a virtualenv, make sure you used the --no-site-packages option"
-- )
-- sys.exit(2)
-- dist = _easy_install(argv, egg)
-- after_install(dist)
-- return
-- #from setuptools.command import easy_install
-- #try:
-- # return easy_install.main(list(argv)+['-v']+[egg])
-- #except DistutilsError:
-- # return sys.exit(2)
-- finally:
-- if egg and os.path.exists(egg):
-- os.unlink(egg)
-- else:
-- if setuptools.__version__ == '0.0.1':
-- print >>sys.stderr, (
-- "You have an obsolete version of setuptools installed. Please\n"
-- "remove it from your system entirely before rerunning this script."
-- )
-- sys.exit(2)
-
- req = "distribute>="+version
- import pkg_resources
@@ -1,14 +0,0 @@
-https://bitbucket.org/tarek/distribute/issue/103/
-
---- setuptools/tests/test_resources.py
-+++ setuptools/tests/test_resources.py
-@@ -536,6 +536,9 @@
- '#!%s -x\n' % self.non_ascii_exe)
-
- def test_get_script_header_jython_workaround(self):
-+ # This test doesn't work with Python 3 in some locales
-+ if sys.version_info >= (3,) and os.environ.get("LC_CTYPE") in (None, "C", "POSIX"):
-+ return
- platform = sys.platform
- sys.platform = 'java1.5.0_13'
- stdout = sys.stdout
@@ -1,50 +0,0 @@
-https://bitbucket.org/tarek/distribute/issue/80/
-https://bitbucket.org/tarek/distribute/changeset/e2de9f1e9064/
-https://bitbucket.org/tarek/distribute/changeset/353a750786ee/
-
---- setuptools/command/__init__.py
-+++ setuptools/command/__init__.py
-@@ -5,13 +5,16 @@
- 'register', 'bdist_wininst', 'upload_docs',
- ]
-
-+from setuptools.command import install_scripts
- import sys
-+
- if sys.version>='2.5':
- # In Python 2.5 and above, distutils includes its own upload command
- __all__.remove('upload')
-
- from distutils.command.bdist import bdist
-
-+
- if 'egg' not in bdist.format_commands:
- bdist.format_command['egg'] = ('bdist_egg', "Python .egg file")
- bdist.format_commands.append('egg')
---- setuptools/command/install_scripts.py
-+++ setuptools/command/install_scripts.py
-@@ -1,6 +1,5 @@
- from distutils.command.install_scripts import install_scripts \
- as _install_scripts
--from easy_install import get_script_args, sys_executable, chmod
- from pkg_resources import Distribution, PathMetadata, ensure_directory
- import os
- from distutils import log
-@@ -13,6 +12,9 @@
- self.no_ep = False
-
- def run(self):
-+ from setuptools.command.easy_install import (get_script_args,
-+ sys_executable)
-+
- self.run_command("egg_info")
- if self.distribution.scripts:
- _install_scripts.run(self) # run first to set up self.outfiles
-@@ -37,6 +39,7 @@
-
- def write_script(self, script_name, contents, mode="t", *ignored):
- """Write an executable file to the scripts directory"""
-+ from setuptools.command.easy_install import chmod
- log.info("Installing %s script to %s", script_name, self.install_dir)
- target = os.path.join(self.install_dir, script_name)
- self.outfiles.append(target)
@@ -1,47 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6-r1.ebuild,v 1.13 2010/10/25 11:17:02 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils multilib-native
-
-MY_PN="distribute"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Distribute (fork of Setuptools) is a collection of extensions to Distutils"
-HOMEPAGE="http://pypi.python.org/pypi/distribute"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="PSF-2.2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="easy_install.py pkg_resources.py setuptools site.py"
-DOCS="README.txt docs/easy_install.txt docs/pkg_resources.txt docs/setuptools.txt"
-
-multilib-native_src_prepare_internal() {
- epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
-
- # Remove tests that access the network (bugs #198312, #191117)
- rm setuptools/tests/test_packageindex.py
-
- sed -e "s/additional_tests/_&/" -i setuptools/tests/__init__.py || die "sed setuptools/tests/__init__.py failed"
- epatch "${FILESDIR}/distribute-${PV}-sandbox.patch"
- epatch "${FILESDIR}/distribute-${PV}-provide_setuptools.patch"
-}
-
-src_test() {
- tests() {
- PYTHONPATH="." "$(PYTHON)" setup.py test
- }
- python_execute_function tests
-}
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.10.ebuild,v 1.10 2010/10/25 11:17:02 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils multilib-native
-
-MY_PN="distribute"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Distribute (fork of Setuptools) is a collection of extensions to Distutils"
-HOMEPAGE="http://pypi.python.org/pypi/distribute"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="PSF-2.2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="easy_install.py pkg_resources.py setuptools site.py"
-DOCS="README.txt docs/easy_install.txt docs/pkg_resources.txt docs/setuptools.txt"
-
-multilib-native_src_prepare_internal() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
-
- # Remove tests that access the network (bugs #198312, #191117)
- rm setuptools/tests/test_packageindex.py
-}
-
-src_test() {
- # test_install_site_py fails with disabled byte-compiling in Python 2.7 / >=3.2.
- python_enable_pyc
-
- tests() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
- }
- python_execute_function tests
-
- python_disable_pyc
- rm -f build-*/lib/site.pyc
-}
-
-multilib-native_src_install_internal() {
- DONT_PATCH_SETUPTOOLS="1" distutils_src_install
-}
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.12.ebuild,v 1.6 2010/10/25 11:17:02 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils multilib-native
-
-MY_PN="distribute"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Distribute (fork of Setuptools) is a collection of extensions to Distutils"
-HOMEPAGE="http://pypi.python.org/pypi/distribute"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="PSF-2.2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="easy_install.py pkg_resources.py setuptools site.py"
-DOCS="README.txt docs/easy_install.txt docs/pkg_resources.txt docs/setuptools.txt"
-
-multilib-native_src_prepare_internal() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
-
- # Remove tests that access the network (bugs #198312, #191117)
- rm setuptools/tests/test_packageindex.py
-
- epatch "${FILESDIR}/distribute-${PV}-disable_versioned_easy_install.patch"
- epatch "${FILESDIR}/distribute-${PV}-fix_deprecation_warnings.patch"
-}
-
-src_test() {
- # test_install_site_py fails with disabled byte-compiling in Python 2.7 / >=3.2.
- python_enable_pyc
-
- distutils_src_test
-
- python_disable_pyc
- find build-* -name "*.pyc" -print0 | xargs -0 rm -f
- find build-* -name "__pycache__" -print0 | xargs -0 rmdir
-}
-
-multilib-native_src_install_internal() {
- DONT_PATCH_SETUPTOOLS="1" distutils_src_install
-}
Oops, something went wrong.

0 comments on commit 189a307

Please sign in to comment.