Permalink
Browse files

removed outdated ebuilds of sys-devel/libtool via auto-sync

  • Loading branch information...
1 parent 278b376 commit c107f86ee7414e74be5f08c4ad973dfa09832b70 @ahuemer ahuemer committed Mar 26, 2011
View
7 sys-devel/libtool/Manifest
@@ -3,20 +3,13 @@ AUX 1.5.20/libtool-1.5.20-override-LD_LIBRARY_PATH.patch 637 RMD160 f46d46cdd9e5
AUX 1.5.20/libtool-1.5.20-use-linux-version-in-fbsd.patch 1185 RMD160 ed02facdc5fd1ea9ffd403f5641f620791d833db SHA1 8d5784695682e3e8a271a9ed635d9d1566c4e99b SHA256 6a17e149e3638c3c94679459e1201f5dd7abbe97e5c8ab3654c1a0d079f53326
AUX 1.5.20/libtool-1.5.20-version-checking.patch 1857 RMD160 25b981402a038a2c4c5ad64066c5f8a5b1416b36 SHA1 c5000fa6da0ffec1d7c48d871db94d8237c949ca SHA256 0d1af5e7024949dcf95bef0d5a47387d0b04b7905d0a55d3349576733783bb6d
AUX 1.5.6/libtool-1.5-filter-host-tags.patch 1608 RMD160 af10d3d3459d07f77ccbdef6080e931e3387af38 SHA1 5d27c058f803cdc1953e82b71f747c2028b78ea0 SHA256 a50cba1c4b799717b21355cc908993c5cdf913b66881992b74b79001f8feb891
-AUX 2.2.6a/libtool-2.2.6a-tests-locale.patch 599 RMD160 be9e1d21e56a36c5d4d959135afa5928298a66b0 SHA1 a4ae6a4df7b0d43d4d09d07f4aed5edccddf6e55 SHA256 3832137bfb2e4cbf00467ec78ab7041bb7f0fc95d91cdee25717d19b8436c1a0
-AUX libtool-2.2.8-versioning-as-needed-test.patch 4015 RMD160 34fab1fdcd32ec0edf0c690ffacbf6f036655c8b SHA1 fb6458a703413117c86eabe082eca67fbf285c24 SHA256 cf316671cc1929c40d23db6d7a9990aba761cbb3890eb163d443805e2ecf2539
DIST libtool-1.3.5.tar.gz 538884 RMD160 0bb20b6802bc790dcbdaecde4058ed06ec77b429 SHA1 0e0a57bcdd4942a872d6b24ff666cfa0dd721452 SHA256 02e287ba621aa01ee581b0f88854deb222fa61e7e0fc55ed7685038354f0259f
DIST libtool-1.5.26.tar.gz 2961939 RMD160 4d1d7dd0308b98e8f590723ae5daddb8da49ac11 SHA1 4c1738351736562a951a345e24f233d00953ec0a SHA256 1c35ae34fe85aa167bd7ab4bc9f477fe019138e1af62678d952fc43c0b7e2f09
DIST libtool-2.2.10.tar.lzma 788637 RMD160 d383b48a110f27dea370e1a060503ff1484deac5 SHA1 f494f82e9f73c0679a76d077b9b54aef2a7bb610 SHA256 6ae978f9674bd1e77bbc9d6309944429d8024c53ce19db24bbed21ad5e70d490
-DIST libtool-2.2.6b.tar.lzma 739089 RMD160 cb209df9819510928c17d36ce8b461bd8418a6a1 SHA1 18baaac89eed8be7bd2af2d2181598e176029cc6 SHA256 66ebad3c02e5cb6672bfbda1183fb6fc919d33d676eb8be4b7834aa7c3b8b7ae
-DIST libtool-2.2.8.tar.lzma 787141 RMD160 ab9fea99cc90a37b52bb0ced945e8f2f5483c2d2 SHA1 e160056cab3b0d31db6c929f12ddd4a77e2a024d SHA256 b94506f767d6f12ae05753c71d4f3e658be5aed080711b3d4d6caa5aacdd4afa
DIST libtool-2.4.tar.xz 852248 RMD160 4955976ce1c7045ef725fbf4e05060f9bd33434b SHA1 a5a44aa791c8b93cbe1c2f839368cd3de5f5f3e1 SHA256 afcce660d3dc54c63a0a5ba3cf05272239dc3c54bbeba20f6bad250f9dc007ae
EBUILD libtool-1.3.5.ebuild 874 RMD160 41b2acd3ede4ba458caf1ae1c29b24239485ea6c SHA1 b00aa2096e6ca55794cdd17c1dd88c0a8efbdeb9 SHA256 6e0c53fb448ef05278d8be8912dfb991e4796c4e8fd442edf1f9f63e64c61afe
EBUILD libtool-1.5.26-r1.ebuild 834 RMD160 a2b86eaef9df006535cca1b0b645dc6abbbded4b SHA1 e9e16543a9348494a41efe7ce6b81f7cd9a6cdd9 SHA256 fee5b1691fe96b7e5e60b12ddf39b4ea497d111f16b8350bf18845ec00051396
EBUILD libtool-1.5.26.ebuild 2903 RMD160 9c043ce97467c257f4fd7c5f5f8231afc9437750 SHA1 a7d2baef418d1d9d71ea6ec25a583aa18f7bd398 SHA256 12bb41285dc05237122bf682c0a883dddbe8c975ad0f88ef5d95a30bdfce3795
EBUILD libtool-2.2.10.ebuild 1959 RMD160 3b254e0f371e1740559888c8fa30e0f6881f449f SHA1 962cfbd08c290f6452f851e5f5516ceaf52d1c11 SHA256 1808db6d85032382b336d28e6b5dbe2f0db9ab9d06657d1057f2337ff5d4a605
-EBUILD libtool-2.2.6b.ebuild 2457 RMD160 c095fcf50ae9be0db1ecef8a30fcc0a326edf9e0 SHA1 f0332e6c62937de5c2e823c3c2facd31385095ca SHA256 be63cfdba718d744884ee9bd1edfab4fa30e3b0b37344cf8fd2e45697c947ccf
-EBUILD libtool-2.2.8-r1.ebuild 2005 RMD160 39ecf9d232e0e6b7bf4960f11901f513d9731ffc SHA1 d353b5063fc28985ffb750ad8c01dc27a55f6042 SHA256 8e931efc1e9888dd1a6606144da5249d777fe50feedad0526da4a3a7bc33b9e2
EBUILD libtool-2.4-r1.ebuild 2022 RMD160 950bfb84cf25b49e95f3cf410ad39d7aa11c9d5a SHA1 780f72f1d3ce17eb331c4dd3fb597cb004f6d1d2 SHA256 87e8041dcbf3298115b3a3733f9a02732cebd9490201542c5d9eb1c6781b6d55
-EBUILD libtool-2.4.ebuild 1957 RMD160 f9d5bed8293cddb2df9a89344afc4a2d78558c40 SHA1 3937e334c7f7b35a39f2a05468f513a0692eaca1 SHA256 7c2f4d1a36ba60893c2bc1ed583d12c8e4494cbd8e2ded3d9247c95553496979
EBUILD libtool-9999.ebuild 1390 RMD160 674d3a9d63d28a520d91141ef0247f759c27103c SHA1 7e2b96fcd84d8c2b4652e27c708d049cd740c7bb SHA256 ba63f516bf3359cc13cc1c0af5f786f9d6ba944e39bbd4a4056dd62d5f83698f
View
12 sys-devel/libtool/files/2.2.6a/libtool-2.2.6a-tests-locale.patch
@@ -1,12 +0,0 @@
-Index: libtool-2.2.6/tests/localization.at
-===================================================================
---- libtool-2.2.6.orig/tests/localization.at
-+++ libtool-2.2.6/tests/localization.at
-@@ -47,6 +47,7 @@ mv -f stdout expected-stdout
- mv -f stderr expected-stderr
- AT_CHECK([$LIBTOOL --mode=compile --tag=CC $CC $CPPFLAGS $CFLAGS -c a.c || exit 1],
- [1], [stdout], [stderr])
-+AT_CHECK([grep LC_ALL stdout stderr && exit 77], [1])
- AT_CHECK([diff expected-stderr stderr])
- LTBASE=`$ECHO "$LIBTOOL" | sed 's,^.*/,,'`
- AT_CHECK([grep -v "^$LTBASE: compile" stdout | diff expected-stdout -])
View
89 sys-devel/libtool/files/libtool-2.2.8-versioning-as-needed-test.patch
@@ -1,89 +0,0 @@
-https://bugs.gentoo.org/321551
-
-From 9a801684f6e1a665dc7126091662b34d042adf68 Mon Sep 17 00:00:00 2001
-From: Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
-Date: Mon, 7 Jun 2010 22:30:44 +0200
-Subject: [PATCH 1/2] Fix versioning test for LDFLAGS=-Wl,--as-needed.
-
-* tests/versioning.at (versioning): For the library update
-hypotheses, ensure the unchanged library libb isn't accidentally
-relinked against the new liba, by not reinstalling libb.
-Fixes testsuite failure for the incompatible update case with
-LDFLAGS=-Wl,--as-needed.
-* THANKS: Update.
-Report by Ryan Hill.
-
-Signed-off-by: Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
----
- tests/versioning.at | 19 +++++++++----------
- 1 files changed, 9 insertions(+), 10 deletions(-)
-
-diff --git a/tests/versioning.at b/tests/versioning.at
-index 136a549..31f294e 100644
---- a/tests/versioning.at
-+++ b/tests/versioning.at
-@@ -1,6 +1,6 @@
- # versioning.at -- test libtool versioning -*- Autotest -*-
- #
--# Copyright (C) 2009 Free Software Foundation, Inc.
-+# Copyright (C) 2009, 2010 Free Software Foundation, Inc.
- #
- # This file is part of GNU Libtool.
- #
-@@ -190,18 +190,17 @@ AT_CHECK([$LIBTOOL --mode=uninstall rm -f $libdir/liba.la], [], [ignore], [ignor
-
-
- # Hypothesis: library revision updates do not require (uninstalled
--# nor installed) programs to be relinked.
-+# nor installed) programs or libraries to be relinked.
- AT_CHECK([$LIBTOOL --mode=link $CC $CFLAGS $LDFLAGS -o liba.la liba2.lo ]dnl
- [-version-info 0:1:0 -rpath $libdir], [], [ignore], [ignore])
- test_uninstalled
--AT_CHECK([$LIBTOOL --mode=install cp liba.la libb.la $libdir],
-- [], [ignore], [ignore])
-+AT_CHECK([$LIBTOOL --mode=install cp liba.la $libdir], [], [ignore], [ignore])
- AT_CHECK([$LIBTOOL --mode=clean rm -f liba.la], [], [ignore], [ignore])
- test_installed
- # do not uninstall here: the library may be reused in the next test.
-
- # Hypothesis: backward compatible library updates do not require
--# (uninstalled nor installed) programs to be relinked.
-+# (uninstalled nor installed) programs or libraries to be relinked.
- # This can have one of several reasons:
- # - the soname is the difference between $current and $age, thus
- # unchanged; in this case, the newly installed library will be used,
-@@ -212,26 +211,26 @@ test_installed
- AT_CHECK([$LIBTOOL --mode=link $CC $CFLAGS $LDFLAGS -o liba.la liba3.lo ]dnl
- [-version-info 1:0:1 -rpath $libdir], [], [ignore], [ignore])
- # Do not test the uninstalled program, it may be broken (in the second case).
--AT_CHECK([$LIBTOOL --mode=install cp liba.la libb.la $libdir],
-- [], [ignore], [ignore])
-+AT_CHECK([$LIBTOOL --mode=install cp liba.la $libdir], [], [ignore], [ignore])
- AT_CHECK([$LIBTOOL --mode=clean rm -f liba.la], [], [ignore], [ignore])
- test_installed
- # do not uninstall here: the library may be reused in the next test.
-
-
- # Hypothesis: with shared libraries, incompatible library updates
--# will not cause old installed programs (linked against the old
-+# will not cause old installed programs or libraries (linked against the old
- # library version) to break.
- # This can have one of several reasons:
- # - the soname has changed, so the old installed library will still be
- # available,
- # - we are linking statically, so the old library code will still be used.
-+# In order to be sure we are still linking against the old library version,
-+# we must ensure that libb is not relinked, so we must not reinstall libb here.
- AT_CHECK([$LIBTOOL --mode=link $CC $CFLAGS $LDFLAGS -o liba.la liba4.lo ]dnl
- [-version-info 2:0:0 -rpath $libdir], [], [ignore], [ignore])
- # We do not guarantee that old versions of an uninstalled library are still
- # available, so test_uninstalled will not necessarily work here any more.
--AT_CHECK([$LIBTOOL --mode=install cp liba.la libb.la $libdir],
-- [], [ignore], [ignore])
-+AT_CHECK([$LIBTOOL --mode=install cp liba.la $libdir], [], [ignore], [ignore])
- AT_CHECK([$LIBTOOL --mode=clean rm -f liba.la], [], [ignore], [ignore])
- test_installed
-
---
-1.7.1
-
View
78 sys-devel/libtool/libtool-2.2.6b.ebuild
@@ -1,78 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.6b.ebuild,v 1.8 2010/07/06 12:41:38 vapier Exp $
-
-EAPI="2"
-
-LIBTOOLIZE="true" #225559
-inherit eutils autotools flag-o-matic multilib multilib-native
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="http://www.gnu.org/software/libtool/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
-
-LICENSE="GPL-2"
-SLOT="1.5"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="vanilla test"
-
-RDEPEND="sys-devel/gnuconfig
- >=sys-devel/autoconf-2.60
- >=sys-devel/automake-1.10.1
- !=sys-devel/automake-1.10"
-DEPEND="${RDEPEND}
- || ( app-arch/xz-utils[lib32?] app-arch/lzma-utils[lib32?] )
- sys-apps/help2man"
-
-multilib-native_pkg_setup_internal() {
- if use test && ! has_version '>sys-devel/binutils-2.19.51'; then
- einfo "Disabling --as-needed, since you got older binutils and you asked"
- einfo "to run tests. With the stricter (older) --as-needed behaviour"
- einfo "you'd be seeing a test failure in test #63; this has been fixed"
- einfo "in the newer version of binutils."
- append-ldflags $(no-as-needed)
- fi
-}
-
-multilib-native_src_prepare_internal() {
- epatch "${FILESDIR}"/2.2.6a/${PN}-2.2.6a-tests-locale.patch #249168
-
- if ! use vanilla ; then
- epunt_cxx
- cd libltdl/m4
- epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- fi
-
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
-}
-
-multilib-native_src_install_internal() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
-
- local x
- for x in libtool libtoolize ; do
- help2man ${x} > ${x}.1
- doman ${x}.1 || die
- done
-
- for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
- rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
- done
-}
-
-multilib-native_pkg_preinst_internal() {
- preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
-}
-
-multilib-native_pkg_postinst_internal() {
- preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
-}
View
66 sys-devel/libtool/libtool-2.2.8-r1.ebuild
@@ -1,66 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.8-r1.ebuild,v 1.1 2010/06/08 21:52:05 vapier Exp $
-
-EAPI="3"
-
-LIBTOOLIZE="true" #225559
-inherit eutils autotools multilib multilib-native
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="http://www.gnu.org/software/libtool/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="vanilla"
-
-RDEPEND="sys-devel/gnuconfig
- >=sys-devel/autoconf-2.60
- >=sys-devel/automake-1.10.1
- !=sys-devel/libtool-2*:1.5"
-DEPEND="${RDEPEND}
- >=sys-devel/binutils-2.20
- || ( app-arch/xz-utils[lib32?] app-arch/lzma-utils[lib32?] )"
-
-multilib-native_src_prepare_internal() {
- epatch "${FILESDIR}"/${P}-versioning-as-needed-test.patch #321551
-
- if ! use vanilla ; then
- epunt_cxx
- cd libltdl/m4
- epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- fi
-}
-
-multilib-native_src_configure_internal() {
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
-
- default
-}
-
-multilib-native_src_install_internal() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
-
- for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
- rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
- done
-}
-
-multilib-native_pkg_preinst_internal() {
- preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
-}
-
-multilib-native_pkg_postinst_internal() {
- preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
-}
View
65 sys-devel/libtool/libtool-2.4.ebuild
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.4.ebuild,v 1.2 2010/11/10 22:58:14 vapier Exp $
-
-EAPI="3"
-
-LIBTOOLIZE="true" #225559
-inherit eutils autotools multilib multilib-native
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="http://www.gnu.org/software/libtool/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="vanilla"
-
-RDEPEND="sys-devel/gnuconfig
- >=sys-devel/autoconf-2.62
- >=sys-devel/automake-1.10.1
- !=sys-devel/automake-1.10
- !=sys-devel/libtool-2*:1.5"
-DEPEND="${RDEPEND}
- >=sys-devel/binutils-2.20
- || ( app-arch/xz-utils[lib32?] app-arch/lzma-utils[lib32?] )"
-
-multilib-native_src_prepare_internal() {
- if ! use vanilla ; then
- epunt_cxx
- cd libltdl/m4
- epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- fi
-}
-
-multilib-native_src_configure_internal() {
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
-
- default
-}
-
-multilib-native_src_install_internal() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
-
- for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
- rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
- done
-}
-
-multilib-native_pkg_preinst_internal() {
- preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
-}
-
-multilib-native_pkg_postinst_internal() {
- preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
-}

0 comments on commit c107f86

Please sign in to comment.