Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

* ext/openssl/deprecation.rb (OpenSSL.check_func): check if header is

  available for macro compatibility.


git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@35507 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
  • Loading branch information...
commit d32155358c67466d038436e6f03d41494043c53b 1 parent 633cebb
@nobu nobu authored
Showing with 12 additions and 2 deletions.
  1. +5 −0 ChangeLog
  2. +7 −2 ext/openssl/deprecation.rb
View
5 ChangeLog
@@ -1,3 +1,8 @@
+Tue May 1 14:17:59 2012 Nobuyoshi Nakada <nobu@ruby-lang.org>
+
+ * ext/openssl/deprecation.rb (OpenSSL.check_func): check if header is
+ available for macro compatibility.
+
Tue May 1 10:53:54 2012 NAKAMURA Usaku <usa@ruby-lang.org>
* test/ruby/test_settracefunc.rb: ignore traces from another threads
View
9 ext/openssl/deprecation.rb
@@ -1,5 +1,5 @@
module OpenSSL
- def self.check_func(func, header)
+ def self.deprecated_warning_flag
unless flag = (@deprecated_warning_flag ||= nil)
if try_compile("", flag = "-Werror=deprecated-declarations")
if with_config("broken-apple-openssl")
@@ -11,6 +11,11 @@ def self.check_func(func, header)
end
@deprecated_warning_flag = flag
end
- have_func(func, header, flag)
+ flag
+ end
+
+ def self.check_func(func, header)
+ have_func(func, header, deprecated_warning_flag) and
+ have_header(header, nil, deprecated_warning_flag)
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.