Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
When installed, allows a user to check for updates in their Rails application
Ruby
tag: 0.0.8

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib
spec
.gitignore
.rspec
.travis.yml
Gemfile
Gemfile.lock
LICENSE
README.markdown
Rakefile
gemlock.gemspec

README.markdown

Gemlock

Provides rake tasks that allow you to check for out of date gems in a project using Bundler.

Travis Status

Build Status

Overview

$ rake gemlock:outdated
rails is out of date!
Installed version: 3.0.10. Latest version: 3.1.0

Gemlock looks at what gems you've specified in your Gemfile, checks the version that that Bundler has set in Gemfile.lock, and lets you know if there's a newer version available.

Installation

  1. Add gem 'gemlock' to your Gemfile
  2. Run bundle install
  3. If you're using Rails, you're done! Otherwise, add require 'gemlock/rake_tasks' to your Rakefile
Something went wrong with that request. Please try again.