Permalink
Browse files

Docs: update supported database version/flavor list in requirements.md

  • Loading branch information...
evanelias committed Jul 9, 2018
1 parent 30ad485 commit 0010a2e7273c5635e9f328bc9810874e85b65fbe
Showing with 8 additions and 2 deletions.
  1. +1 −1 NOTICE
  2. +7 −1 doc/requirements.md
View
2 NOTICE
@@ -1,4 +1,4 @@
Copyright 2016 Skeema LLC
Copyright 2018 Skeema LLC
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
View
@@ -2,7 +2,13 @@
### MySQL version and flavor
Skeema is tested extensively against MySQL 5.6 and 5.7, running on Linux. Percona Server 5.6 and 5.7 should also work fine. Only the InnoDB storage engine is primarily supported; other storage engines are often perfectly functional in Skeema, but it depends on whether any esoteric features of the engine are used.
Skeema currently supports the following databases:
* MySQL 5.5, 5.6, 5.7
* Percona Server 5.6, 5.7
* MariaDB 10.1, 10.2, 10.3
Only the InnoDB storage engine is primarily supported. Other storage engines are often perfectly functional in Skeema, but it depends on whether any esoteric features of the engine are used.
Some MySQL features -- such as partitioned tables, fulltext indexes, and generated/virtual columns -- are not yet supported in Skeema's diff operations. Skeema automatically detects this situation, so there is no risk of generating an incorrect diff. If Skeema does not yet support a table/column feature that you need, please open a GitHub issue so that the work can be prioritized appropriately.

0 comments on commit 0010a2e

Please sign in to comment.