version 1.1.0

@seratch seratch released this Jun 15, 2014 · 872 commits to master since this release

Thanks to Scalatra team's work, we can announce Skinny Framework 1.1.0 release now.

http://skinny-framework.org/

Topics

Skinny 1.1 APIs are basically compatible with Skinny 1.0 though the release includes basic dependencies' major upgrades. All the features should be kept since 1.0.18.

Typical Migration Tasks

org.scalatest.matchers.ShouldMatchers is deprecated

Use org.scalatest.Matchers instead. Sorry to say this.

importing scalikejdbc.SQLInterpolation._ is deprecated

Just import only scalikejdbc._.

See also: 1e44f60

skinny package's Scalate precompilation error

Since Scalate 1.7.0, Skinny's blank app project's settings fail to execute package command.

default_ssp.scala:7: $_scalate_$default_ssp is already defined as object $_scalate_$default_ssp

See also: 4ad2b87

Though we believe migration is not difficult, please tell us here if you find something wrong.

https://github.com/skinny-framework/skinny-framework/issues

Changes

  • [all] started building for both of Scala 2.10 and 2.11
  • [assets] #144 Add Locale.English to the date formats in AssetsController by @argius
  • [balnk-app] Enabled sbt-scoverage by default (works with Scala 2.11)
  • [framework] Bumped Scalatra from 2.2 to 2.3
  • [framework] Bumped Scalate from 1.6 to 1.7 (same as Scalatra 2.3)
  • [framework] Support Java 7 or higher (same as Scalatra 2.3)
  • [framework] Servlet API 3.1 or higher (same as Scalatra 2.3)
  • [orm] Bumped ScalikeJDBC from 1.8 to 2.0 (ScalaTest 1.9 incompatible)
  • [orm] Bumped Flyway from 2.3 to 3.0
  • [test] ScalaTest 2.2 (incompatible with ScalaTest 1.9)