Can't build test suite #2

Closed
snoyberg opened this Issue Sep 2, 2013 · 3 comments

Projects

None yet

2 participants

@snoyberg
snoyberg commented Sep 2, 2013

I am unable to build the test suite currently. I get the following error message:

In-place registering xmlgen-0.6.1.0...
Preprocessing test suite 'xmlgen-tests' for xmlgen-0.6.1.0...
<command line>: cannot satisfy -package-id xmlgen-0.6.1.0-inplace: 
    xmlgen-0.6.1.0-inplace is shadowed by package xmlgen-0.6.1.0-6be9e93efe6d42c370cbb7b19b8dac40
    (use -v for more information)

Taking a wild stab in the dark: is this relying on some new functionality in Cabal 1.18 for recursive dependencies?

@snoyberg snoyberg added a commit to fpco/stackage that referenced this issue Sep 2, 2013
@snoyberg snoyberg Don't run xmlgen tests skogsbaer/xmlgen#2 b82e348
@skogsbaer
Owner

I couldn't reproduce your exact problem but had other issues running the tests in a fresh install, namely that xmlgen and HTF have circular dependencies. There is a new commit that removes the HTF dependency from xmlgen.

Please try the new xmlgen version. If it solves your problem I'll also upload to hackage.

@snoyberg
snoyberg commented Sep 2, 2013

Seems to work for me.

@skogsbaer
Owner

Ok, uploaded 0.6.2.0 to hackage.

@skogsbaer skogsbaer closed this Sep 3, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment