Permalink
Browse files

No more awesome :)

  • Loading branch information...
skyeagle committed Sep 7, 2010
1 parent ea9a05f commit 2d3e9632531ea198e91941ffc710e37148bc07cf
View
@@ -1,7 +1,25 @@
-*.gemspec
+## MAC OS
+.DS_Store
+
+## TEXTMATE
+*.tmproj
+tmtags
+
+## EMACS
+*~
+\#*
+.\#*
+
+## VIM
+*.swp
+
+## PROJECT::GENERAL
+coverage
+rdoc
+pkg
+
+# PROJECT::SPECIFIC
awesome_nested_set.sqlite3.db
test/debug.log
rdoc
-coverage
-pkg
*.sw?
View
@@ -1,57 +1,53 @@
# encoding: utf-8
require 'rubygems'
+require 'rake'
+
begin
require 'jeweler'
+ Jeweler::Tasks.new do |gem|
+ gem.name = "nested_set"
+ gem.summary = "An awesome nested set implementation for Active Record"
+ gem.description = s.summary
+ gem.email = "info@collectiveidea.com"
+ gem.homepage = "http://github.com/collectiveidea/awesome_nested_set"
+ gem.authors = ["Brandon Keepers", "Daniel Morrison"]
+ gem.add_dependency "activerecord", ['>= 3.0.0.rc']
+ end
+ Jeweler::GemcutterTasks.new
rescue LoadError
- puts "Jeweler not available. Install it with: sudo gem install jeweler"
- exit 1
+ puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
end
+
require 'rake/testtask'
-require 'rake/rdoctask'
-require 'rcov/rcovtask'
-#require "load_multi_rails_rake_tasks"
+Rake::TestTask.new(:test) do |test|
+ test.libs << 'lib' << 'test'
+ test.pattern = 'test/**/test_*.rb'
+ test.verbose = true
+end
-Jeweler::Tasks.new do |s|
- s.name = "be9-awesome_nested_set"
- s.summary = "An awesome nested set implementation for Active Record"
- s.description = s.summary
- s.email = "info@collectiveidea.com"
- s.homepage = "http://github.com/collectiveidea/awesome_nested_set"
- s.authors = ["Brandon Keepers", "Daniel Morrison"]
- s.add_dependency "activerecord", ['>= 3.0.0.rc']
- s.has_rdoc = true
- s.extra_rdoc_files = [ "README.rdoc"]
- s.rdoc_options = ["--main", "README.rdoc", "--inline-source", "--line-numbers"]
- s.test_files = Dir['test/**/*.{yml,rb}']
+begin
+ require 'rcov/rcovtask'
+ Rcov::RcovTask.new do |test|
+ test.libs << 'test'
+ test.pattern = 'test/**/test_*.rb'
+ test.verbose = true
+ end
+rescue LoadError
+ task :rcov do
+ abort "RCov is not available. In order to run rcov, you must: sudo gem install spicycode-rcov"
+ end
end
- Jeweler::GemcutterTasks.new
-desc 'Default: run unit tests.'
+task :test => :check_dependencies
+
task :default => :test
-desc 'Test the awesome_nested_set plugin.'
-Rake::TestTask.new(:test) do |t|
- t.libs += ['lib', 'test']
- t.pattern = 'test/**/*_test.rb'
- t.verbose = true
-end
+require 'rake/rdoctask'
+Rake::RDocTask.new do |rdoc|
+ version = File.exist?('VERSION') ? File.read('VERSION') : ""
-desc 'Generate documentation for the awesome_nested_set plugin.'
-Rake::RDocTask.new(:rdoc) do |rdoc|
rdoc.rdoc_dir = 'rdoc'
- rdoc.title = 'AwesomeNestedSet'
- rdoc.options << '--line-numbers' << '--inline-source'
- rdoc.rdoc_files.include('README.rdoc')
+ rdoc.title = "nested_set #{version}"
+ rdoc.rdoc_files.include('README*')
rdoc.rdoc_files.include('lib/**/*.rb')
end
-
-namespace :test do
- desc "just rcov minus html output"
- Rcov::RcovTask.new(:coverage) do |t|
- t.libs << 'test'
- t.test_files = FileList['test/**/*_test.rb']
- t.output_dir = 'coverage'
- t.verbose = true
- t.rcov_opts = %w(--exclude test,/usr/lib/ruby,/Library/Ruby,lib/awesome_nested_set/named_scope.rb --sort coverage)
- end
-end
View
@@ -1,71 +0,0 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE
-# Instead, edit Jeweler::Tasks in Rakefile, and run `rake gemspec`
-# -*- encoding: utf-8 -*-
-
-Gem::Specification.new do |s|
- s.name = %q{awesome_nested_set}
- s.version = "1.4.3"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Brandon Keepers", "Daniel Morrison"]
- s.date = %q{2009-10-07}
- s.description = %q{An awesome nested set implementation for Active Record}
- s.email = %q{info@collectiveidea.com}
- s.extra_rdoc_files = [
- "README.rdoc"
- ]
- s.files = [
- ".autotest",
- ".gitignore",
- "MIT-LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "awesome_nested_set.gemspec",
- "init.rb",
- "lib/awesome_nested_set.rb",
- "lib/awesome_nested_set/helper.rb",
- "rails/init.rb",
- "test/application.rb",
- "test/awesome_nested_set/helper_test.rb",
- "test/awesome_nested_set_test.rb",
- "test/db/database.yml",
- "test/db/schema.rb",
- "test/fixtures/categories.yml",
- "test/fixtures/category.rb",
- "test/fixtures/departments.yml",
- "test/fixtures/notes.yml",
- "test/test_helper.rb"
- ]
- s.homepage = %q{http://github.com/collectiveidea/awesome_nested_set}
- s.rdoc_options = ["--main", "README.rdoc", "--inline-source", "--line-numbers"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.5}
- s.summary = %q{An awesome nested set implementation for Active Record}
- s.test_files = [
- "test/db/database.yml",
- "test/fixtures/categories.yml",
- "test/fixtures/departments.yml",
- "test/fixtures/notes.yml",
- "test/application.rb",
- "test/awesome_nested_set/helper_test.rb",
- "test/awesome_nested_set_test.rb",
- "test/db/schema.rb",
- "test/fixtures/category.rb",
- "test/test_helper.rb"
- ]
-
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
-
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord>, [">= 1.1"])
- else
- s.add_dependency(%q<activerecord>, [">= 1.1"])
- end
- else
- s.add_dependency(%q<activerecord>, [">= 1.1"])
- end
-end
View
@@ -1,13 +0,0 @@
-# encoding: utf-8
-module CollectiveIdea
- module Acts
- module NestedSet
- autoload :Base, 'awesome_nested_set/base'
- autoload :Depth, 'awesome_nested_set/depth'
- autoload :Descendants, 'awesome_nested_set/descendants'
- autoload :Helper, 'awesome_nested_set/helper'
- end
- end
-end
-
-require 'awesome_nested_set/railtie'
View
@@ -0,0 +1,13 @@
+# encoding: utf-8
+module CollectiveIdea
+ module Acts
+ module NestedSet
+ autoload :Base, 'nested_set/base'
+ autoload :Depth, 'nested_set/depth'
+ autoload :Descendants, 'nested_set/descendants'
+ autoload :Helper, 'nested_set/helper'
+ end
+ end
+end
+
+require 'nested_set/railtie'
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
View
@@ -1,2 +1,2 @@
# encoding: utf-8
-require "awesome_nested_set"
+require "nested_set"

0 comments on commit 2d3e963

Please sign in to comment.