New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Sequential printing issue #2007

Closed
Leary opened this Issue May 5, 2014 · 3 comments

Comments

Projects
None yet
2 participants
@Leary

Leary commented May 5, 2014

Using 1.1.2 experimental

Using sequential printing, with a 2 loop skirt. When the first object completed, the extruder moved away in x and y, then dropped down to the beginning z height before moving the x and y to the start of the next object. This resulted in the hot end dragging across the skirt, dislodging it and causing a failure.

; complete_objects = 1
; extruder_clearance_height = 20
; extruder_clearance_radius = 20
; skirt_distance = 5
; skirt_height = 2
; skirts = 2

Making the XY move prior to the z move would alleviate the issue.

This snippet of gcode demonstrates the current behavior.

G1 X88.152 Y120.826 F9000.000 ; End of first object
G1 F1800.000 E4.70804 ;
G1 Z8.800 F9000.000 ;
G92 E0 ;
G1 X209.834 Y204.445 F9000.000 ; move away
M140 S110 ; set bed temperature ;
M104 S235 ; set temperature ;
M107 ;
G1 Z0.350 F9000.000 ; return to starting z height
G1 X173.843 Y142.362 F9000.000 ; move to start of next object
G1 E1.00000 F1800.000 ;
G1 X177.010 Y145.020 E1.07447 F2040.000 ;

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj May 21, 2014

Member

Okay, thick skirt was probably not taken into account when implementing sequential printing.

However I need a reproducible test case since I need to troubleshoot the "move away" G1 command. Can you provide STL and exported config.ini please? Thank you

Member

alexrj commented May 21, 2014

Okay, thick skirt was probably not taken into account when implementing sequential printing.

However I need a reproducible test case since I need to troubleshoot the "move away" G1 command. Can you provide STL and exported config.ini please? Thank you

@Leary

This comment has been minimized.

Show comment
Hide comment

Leary commented May 22, 2014

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj May 26, 2014

Member

Thank you for providing files.
So, the issue was not about moving onto skirt. There was a bad travel move going very far away, this outside the skirt. No travel move should go outside skirt, actually, so no risk of scratching against tall skirts.

I fixed this now and added a regression test.

Member

alexrj commented May 26, 2014

Thank you for providing files.
So, the issue was not about moving onto skirt. There was a bad travel move going very far away, this outside the skirt. No travel move should go outside skirt, actually, so no risk of scratching against tall skirts.

I fixed this now and added a regression test.

@alexrj alexrj closed this May 26, 2014

@alexrj alexrj added Fixed and removed Needs details labels May 26, 2014

@alexrj alexrj added this to the 1.1.3 milestone May 26, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment