New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Brim remembered from previous export #2024

Closed
kefir- opened this Issue May 8, 2014 · 2 comments

Comments

Projects
None yet
3 participants
@kefir-

kefir- commented May 8, 2014

Testing with slic3r c72dc13 (just after v1.1.2), I noticed something odd. I did the following:

  1. Loaded slic3r, and enabled 4mm brim. Then I plated some parts with slic3r, exported the gcode, and printed it.
  2. Next I plated some new parts, but forgot to remove the brim (which I didn't want any more). I exported gcode with the brim.
  3. I set the brim to 0 in the config, and exported the same plate again. Then I decided this print would take too long today, so I never printed it.
  4. I deleted everything from the plate, and loaded a single part. I sliced it (still without brim), and started printing it.

At this point, the part was printed without the brim, but strangely the brim from step 2 was still part of the print. Here's the gcode:

http://kefirshare.dreamhosters.com/planets_20140508-224006_1.1.3-dev.gcode

And here's a screenshot showing the issue:

old-brim

Let me know if you need any more info, but this case seems like a logic issue somewhere that doesn't require STL and other info.

@kefir- kefir- changed the title from Brim remembered from last export to Brim remembered from previous export May 8, 2014

@traveltrousers

This comment has been minimized.

Show comment
Hide comment
@traveltrousers

traveltrousers May 10, 2014

Also happened to me.... on 1.1.2 also I believe.....

traveltrousers commented May 10, 2014

Also happened to me.... on 1.1.2 also I believe.....

alexrj added a commit that referenced this issue May 10, 2014

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj May 10, 2014

Member

Whoops! Brim wasn't cleared when option was set to 0. Fixed.

Member

alexrj commented May 10, 2014

Whoops! Brim wasn't cleared when option was set to 0. Fixed.

@alexrj alexrj closed this May 10, 2014

@alexrj alexrj added this to the 1.1.3 milestone May 10, 2014

@alexrj alexrj added the Fixed label May 10, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment