New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Slic3r crashes when opening Object Settings dialog 2nd time #2099

Closed
vitalif opened this Issue Jun 16, 2014 · 7 comments

Comments

Projects
None yet
4 participants
@vitalif

vitalif commented Jun 16, 2014

Hi, I'm still talking about master branch of Slic3r... the bug reproduces at least since 1.1.2-dev.
The bug is very simple - when I'm trying to open Object Settings dialog 2nd time, Slic3r crashes with BadDrawable X11 error.
I've fixed it like this: vitalif/Slic3r@e73d76e (so canvas is not repainted while creating window)
Don't know if it's the best way to fix issue, but it definitely needs a fix :)

@Lenbok

This comment has been minimized.

Show comment
Hide comment
@Lenbok

Lenbok Jun 19, 2014

Contributor

Duplicate of #2015

Contributor

Lenbok commented Jun 19, 2014

Duplicate of #2015

@Lenbok

This comment has been minimized.

Show comment
Hide comment
@Lenbok

Lenbok Jun 19, 2014

Contributor

BTW - maybe issue a pull request so it is obvious there is a possible solution?

Contributor

Lenbok commented Jun 19, 2014

BTW - maybe issue a pull request so it is obvious there is a possible solution?

@vitalif

This comment has been minimized.

Show comment
Hide comment
@vitalif

vitalif Jun 19, 2014

See commit link in the first comment. I can cherry-pick it and resubmit it as a pull request...

vitalif commented Jun 19, 2014

See commit link in the first comment. I can cherry-pick it and resubmit it as a pull request...

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj Jun 19, 2014

Member

What's your wxWidgets version? You can see that by running ./slic3r.pl --debug --gui

Member

alexrj commented Jun 19, 2014

What's your wxWidgets version? You can see that by running ./slic3r.pl --debug --gui

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj Jun 19, 2014

Member

Nevermind, I fixed this. Thanks for reporting

Member

alexrj commented Jun 19, 2014

Nevermind, I fixed this. Thanks for reporting

@swiftgeek

This comment has been minimized.

Show comment
Hide comment
@swiftgeek

swiftgeek Aug 4, 2014

LLVMpipe: LIBGL_ALWAYS_SOFTWARE=1 slic3r.pl
"BadDrawable" on main Window (via titlebar) close, Object settings via OK button

Indirect rendering: LIBGL_ALWAYS_INDIRECT=1 slic3r.pl
"GLXBadDrawable" on trying to display any 3d content

Current master + perl 5.20
Mesa exports for reproducing errors without having affected, older HW
Works without any errors on Nouveau/NV50 without those exports

swiftgeek commented Aug 4, 2014

LLVMpipe: LIBGL_ALWAYS_SOFTWARE=1 slic3r.pl
"BadDrawable" on main Window (via titlebar) close, Object settings via OK button

Indirect rendering: LIBGL_ALWAYS_INDIRECT=1 slic3r.pl
"GLXBadDrawable" on trying to display any 3d content

Current master + perl 5.20
Mesa exports for reproducing errors without having affected, older HW
Works without any errors on Nouveau/NV50 without those exports

@alexrj alexrj reopened this Aug 5, 2014

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj Jun 2, 2015

Member

Can be closed now.

Member

alexrj commented Jun 2, 2015

Can be closed now.

@alexrj alexrj closed this Jun 2, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment