New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Point not found" error when exporting G-code from command line #2306

Closed
harriv opened this Issue Oct 17, 2014 · 5 comments

Comments

Projects
None yet
4 participants
@harriv
Contributor

harriv commented Oct 17, 2014

I'm running latest version from Git, and when slicing model I get this:

$ ./slic3r.pl T4MiniBody.stl
Running Slic3r under Perl >= 5.16 is not supported nor recommended
=> Processing triangulated mesh
=> Generating perimeters
=> Preparing infill
=> Infilling layers
=> Generating skirt
=> Exporting G-code to ./T4MiniBody.gcode
Error in function split_at_vertex at src/libslic3r/ExtrusionEntity.cpp:263: Point not found
at /home/harriv/slic3r/Slic3r/lib/Slic3r/GCode.pm line 183.
Slic3r::GCode::extrude_loop('Slic3r::GCode=HASH(0x94534f4)', 'Slic3r::ExtrusionLoop::Ref=SCALAR(0x96669e0)', 'perimeter') called at /home/harriv/slic3r/Slic3r/lib/Slic3r/GCode.pm line 134
Slic3r::GCode::extrude('Slic3r::GCode=HASH(0x94534f4)', 'Slic3r::ExtrusionLoop::Ref=SCALAR(0x96669e0)', 'perimeter') called at /home/harriv/slic3r/Slic3r/lib/Slic3r/GCode/Layer.pm line 215
Slic3r::GCode::Layer::_extrude_perimeters('Slic3r::GCode::Layer=HASH(0x8bd83d4)', 'ARRAY(0x9726fd0)', 'Slic3r::Print::Region::Ref=SCALAR(0x966683c)') called at /home/harriv/slic3r/Slic3r/lib/Slic3r/GCode/Layer.pm line 183
Slic3r::GCode::Layer::process_layer('Slic3r::GCode::Layer=HASH(0x8bd83d4)', 'Slic3r::Layer::Ref=SCALAR(0x971b8e4)', 'ARRAY(0x96f59c0)') called at /home/harriv/slic3r/Slic3r/lib/Slic3r/Print.pm line 925
Slic3r::Print::write_gcode('Slic3r::Print=SCALAR(0x9459654)', './T4MiniBody.gcode') called at /home/harriv/slic3r/Slic3r/lib/Slic3r/Print.pm line 395
Slic3r::Print::export_gcode('Slic3r::Print=SCALAR(0x9459654)', 'output_file', undef) called at /home/harriv/slic3r/Slic3r/lib/Slic3r/Print/Simple.pm line 96
Slic3r::Print::Simple::export_gcode('Slic3r::Print::Simple=HASH(0x93742e0)') called at ./slic3r.pl line 204

$ git rev-parse HEAD
6b8f03f

Model is this one: http://www.thingiverse.com/download:718624

Running Ubuntu 14.04, x86.

Exporting GCode from GUI seems to work ok.

@harriv harriv changed the title from "Point not found" error when exporting G-code to "Point not found" error when exporting G-code from command line Oct 17, 2014

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj Oct 17, 2014

Member

I can't reproduce this on OS X. I will try on Ubuntu.

Member

alexrj commented Oct 17, 2014

I can't reproduce this on OS X. I will try on Ubuntu.

@alexrj alexrj added this to the 1.2.1 milestone Oct 17, 2014

@bethebeer

This comment has been minimized.

Show comment
Hide comment
@bethebeer

bethebeer Oct 23, 2014

I believe that issue 2308 is the same as this one. I got the error using the GUI(1.2.0) on Mac OSX 10.10.

bethebeer commented Oct 23, 2014

I believe that issue 2308 is the same as this one. I got the error using the GUI(1.2.0) on Mac OSX 10.10.

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj Nov 8, 2014

Member

Okay, I can reproduce this on Ubuntu x68 with current HEAD.

Member

alexrj commented Nov 8, 2014

Okay, I can reproduce this on Ubuntu x68 with current HEAD.

alexrj added a commit that referenced this issue Nov 8, 2014

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj Nov 8, 2014

Member

I fixed this. It was caused by the Clipper library changing some point coordinates in x86. I applied a workaround.

Member

alexrj commented Nov 8, 2014

I fixed this. It was caused by the Clipper library changing some point coordinates in x86. I applied a workaround.

@kyrreaa

This comment has been minimized.

Show comment
Hide comment
@kyrreaa

kyrreaa Feb 23, 2015

Just a note:
I encountered this in 1.2.5 Experimental, but not in 1.2.6 Experimental.
G-code data ends in middle of "sentence" and a partial model is printed on some complex models.
(I cannot share the file that fails unfortunately, trying to reproduce with a open file.)
Platform was 32 bit x86 which seems to fit the original issue.

kyrreaa commented Feb 23, 2015

Just a note:
I encountered this in 1.2.5 Experimental, but not in 1.2.6 Experimental.
G-code data ends in middle of "sentence" and a partial model is printed on some complex models.
(I cannot share the file that fails unfortunately, trying to reproduce with a open file.)
Platform was 32 bit x86 which seems to fit the original issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment