New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[1.2.7-dev] Part/Object settings window incorrect initialization #2762

Closed
Lenbok opened this Issue Mar 29, 2015 · 2 comments

Comments

Projects
None yet
2 participants
@Lenbok
Contributor

Lenbok commented Mar 29, 2015

When I open the part settings it initially looks like this:
image
I would expect that straight after opening this window I should be able to start adding settings. After all, the '+' icon is present. However, this does not work.

In the tree view it looks like it should currently be in "Object Settings" mode, but the settings area below is labelled "Part Settings". Note that this settings area no section for the Extruder. Clicking on the '+' icon does not bring up a list of settings that can be applied.

If you click on the part name (in this case vacuum-pipe-lock), the "Extruders" section appears and per-part settings can now be chosen via '+'.
image

Clicking on "Object" to switch to "Object Settings" now contains the missing Extruders section and object settings can now be chosen via '+'.
image

It seems like this window is being initialized incorrectly so it isn't completely in either Object Settings or Part Settings.

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj Mar 30, 2015

Member

Good catch...

Member

alexrj commented Mar 30, 2015

Good catch...

@alexrj alexrj added this to the 1.2.7 milestone Mar 30, 2015

@alexrj

This comment has been minimized.

Show comment
Hide comment
@alexrj

alexrj Mar 30, 2015

Member

Fixed. Thank you!

Member

alexrj commented Mar 30, 2015

Fixed. Thank you!

@alexrj alexrj closed this Mar 30, 2015

alexrj added a commit that referenced this issue Mar 30, 2015

@alexrj alexrj added the Fixed label Mar 30, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment