Syntax Highlighting is broken :( #23

Closed
ghost opened this Issue Oct 15, 2012 · 12 comments

3 participants

@ghost

Is it just me or is syntax highlighting not working since #22?

@DAddYE

+1 !!!!

@darthdeus

Could you provide a sample where it doesn't work? I'm using it on the master branch in a quite large project and it works fine for me.

If you're talking about embedding another syntax in slim, such as ruby/javascript/coffeescript, those were intentionally removed from the plugin for pure performance reasons in #22. You can checkout ec1f885 if you need the additional syntaxes.

But at least from my perspective, it's not really a good practice to have a lot of embedded languages in your HTML templates, if that's the case.

@ghost

@darthdeus an example for this behavior would be this file. It looks some kind of broken and weird if you use the latest git version of vim-slim.

@DAddYE
@darthdeus

This is basically partial revert of the performance tweaks I did in #22, caused by deleting haml syntax, which is somehow used for tag highlighting if I understand this correctly.

But some attributes, like data-foo are still not highlighted properly ... I'm going to take a look at it some more.

@ghost

But some attributes, like data-foo are still not highlighted properly ... I'm going to take a look at it some more.

Those weren't highlighted before your changes.

@DAddYE
@darthdeus

@DAddYE It has the same syntax highlighting as in the initial commit, so there's nothing really to revert.

As far as I know the data-foo comes from default HTML highlighting, so I'm not sure how to change that. But I might be wrong on that one.

@DAddYE

mmm, yep because before it uses the haml syntax, now without that any html tag is not highlighted. In this case we can use plain text which is the same no ?

@DAddYE

for those how want back the old syntax highlighting https://github.com/DAddYE/vim-slim

@maletor

+1 this is broken from #22.

@ghost Unknown pushed a commit that closed this issue Oct 26, 2012
@darthdeus darthdeus Fix #23 - broken tag highlighting 9cc1520
@ghost ghost closed this in 9cc1520 Oct 26, 2012
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment